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●Use of Product and This Manual 

 

1. In order to use the Myway Plus product indicated in this manual, carefully read the 

method of use and the information regarding the product provided by our company 

including this manual, and follow the contents before using our product for protection 

and safe use of our product, and systems controlled by our product. 

In cases where our product is used in environments which do not meet the acceptable 

operating environment specified by our company required for reliable operation, or the 

customer uses the product in a manner beyond our expectations, or modifications are 

performed by the customer, the function of the product may not be sufficiently 

demonstrated due to impairments in the protective functions or other reasons. Myway 

Plus assumes no liability for damages or etc., resulting from the improper operation or 

misuse by the customer or third parties. 

2. Myway Plus products are not designed or manufactured for the purpose of being used 

for military purposes or in applications or conditions directly related to human life, such 

as nuclear power equipment, aircraft instruments and medical instruments. Do not use 

our product for these applications. 

3. Myway Plus continuously strives to improve the quality and reliability of our products; 

however, this does not completely guarantee that no troubles will occur. When 

assembling the product indicated in this manual into equipment, be sure that measures 

are taken for safety and reliability, such as systematically installing a backup or fail safe 

function. 

4. Myway Plus assumes no liability regarding the infringement of the patent rights, copy 

rights or any other rights of third parties, which occur in connection with the use of the 

product indicated in this manual. Moreover, Myway Plus does not permit or guarantee 

implementation or use of the patent rights, copy rights or any other intellectual property 

rights of our company or third parties, based on this manual. 

5. Reproduction, copying or duplication of all or portions of this product indicated in this 

manual and this manual are strictly prohibited without obtaining prior consent from 

Myway Plus. In addition, company names and trade names indicated in this manual are 

the trademarks, or registered trademarks of each company. 

6. The specifications of the product indicated in this manual, and the sales conditions may 

be changed without prior notice. After the warranty period has expired, the contents may 

be changed without prior notice. We appreciate your understanding of the above. 

7. Windows is a registered trademark of Microsoft Corporation in the U.S. and other 

countries. In addition, company names and trade names indicated in this manual are the 
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trademarks, or registered trademarks of each company. 

8. Please contact Myway Plus regarding any unclear points regarding the contents of this 

manual. 

 

●Storage and Operating Environment 

 

The product indicated in this manual, is based on it being used in Japan and indoors, and 

operation is not guaranteed if the product is used in the following environments. Pay 

attention when storing and using this product. 

1. Environments with excessively high temperatures, low temperatures or where 

temperatures changes drastically, and environments where high humidity or 

condensation are generated 

2. Environments with large shocks, vibrations and noise, and environments with 

excessive dust 

3. Environments close to large magnetic fields or electric fields, or environments where 

static tends to occur 

4. Environments where there is possible contact with chemicals, and environments 

where chemicals tend to evaporate 

5. Environments with an unspecified power supply, such as use in a foreign country, or 

use with other than a commercial power supply 

 

Copyright (C) 2015 Myway Plus Corporation 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 4/217 2017/09/19 

 

Table of Contents 

Chapter 1 Outline ................................................................................................................... 7 

1.1 Features ....................................................................................................................... 7 

1.2 Operating Environment .............................................................................................. 8 

1.3 Regarding License ...................................................................................................... 9 

1.4 Regarding Connection to PE-Expert4 ...................................................................... 9 

Chapter 2 Screen Structure ............................................................................................... 10 

2.1 Outline ........................................................................................................................ 10 

2.2 Main Window .............................................................................................................. 11 

2.3 Menu ............................................................................................................................ 11 

2.4 Tool Buttons .............................................................................................................. 13 

2.5 Sub Windows ............................................................................................................ 14 

Chapter 3 Program Development Procedure .................................................................. 17 

3.1 Starting PE-ViewX ..................................................................................................... 17 

3.2 Copy Samples ........................................................................................................... 19 

(i) Copy the samples when activation ....................................................................... 19 

(ii) Copy the samples after opening PE-ViewX ...................................................... 19 

3.3 Various Settings ........................................................................................................ 21 

3.3.1 IP Address ........................................................................................................... 22 

3.3.2 Editor ................................................................................................................... 25 

3.3.3 Tool Buttons ....................................................................................................... 26 

3.3.4 Compiler Path ..................................................................................................... 27 

3.3.5 Copy Samples ...................................................................................................... 29 

3.3.6 External Coupling ................................................................................................. 29 

3.3.7 Offset of timeout ................................................................................................... 42 

3.3.8 Data Table ............................................................................................................ 43 

3.4 Project Settings ........................................................................................................ 45 

3.4.1 Create .................................................................................................................. 45 

3.4.2 Open .................................................................................................................... 50 

3.4.3 Copy .................................................................................................................... 52 

3.4.4 Properties............................................................................................................ 53 

3.5 Editing Source Files, Etc. ........................................................................................ 54 

3.5.1 Editing Source Files........................................................................................... 55 

3.5.2 Adding Source Files .......................................................................................... 55 

3.5.3 Adding Reference Destination of Header Files .............................................. 56 

3.6 Compiling .................................................................................................................. 57 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 5/217 2017/09/19 

 

3.7 Downloading ............................................................................................................. 59 

3.7.1 Executing Download .......................................................................................... 59 

3.7.2 Notes ................................................................................................................... 60 

3.8 Verify .......................................................................................................................... 61 

3.8.1 Executing Verify ................................................................................................. 61 

3.8.2 Notes ................................................................................................................... 62 

3.9 Execute/Stop ............................................................................................................. 63 

3.9.1 Execute/Stop Functions .................................................................................... 63 

3.10 Debug Functions .................................................................................................... 65 

Chapter 4 Sub Windows .................................................................................................... 66 

4.1 Explorer Window ...................................................................................................... 66 

4.1.1 Project ................................................................................................................. 67 

4.1.2 Source ................................................................................................................. 68 

4.1.2 Include ................................................................................................................. 72 

4.1.3 Object/Library ..................................................................................................... 76 

4.1.3 Configuration ...................................................................................................... 79 

4.1.4 Mode .................................................................................................................... 80 

4.2 Console Window ....................................................................................................... 81 

4.3 Inspector Window ..................................................................................................... 84 

4.3.1 Structure of Fields ............................................................................................. 85 

4.3.2 Reading/Writing Variables ................................................................................. 90 

4.3.3 Changing Display Format ................................................................................. 93 

4.3.4 Menu .................................................................................................................... 93 

4.3.5 Context Menu ..................................................................................................... 94 

4.3.6 Notes ................................................................................................................... 95 

4.4 WAVE Window ........................................................................................................... 96 

4.4.1 Starting ................................................................................................................ 96 

4.4.2 Screen Structure ................................................................................................ 97 

4.4.3 Outline of WAVE Function ................................................................................. 99 

4.4.4 Control Panel Window Functions .................................................................. 103 

4.4.5 Graph Window Structure ................................................................................. 134 

4.4.6 Processing Waveform Data ([File] Menu) ...................................................... 139 

4.4.7 Waveform Display Related Settings ([Option] Menu) .................................. 143 

4.4.8 FFT Analysis Display ....................................................................................... 151 

4.4.9 DMM Display ..................................................................................................... 157 

4.4.10 Short-cut Keys ................................................................................................ 159 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 6/217 2017/09/19 

 

4.4.11 Notes ................................................................................................................ 163 

4.5 [Memory] Window ................................................................................................... 164 

4.5.1 Reading Memory .............................................................................................. 165 

4.5.2 Context Menu ................................................................................................... 166 

4.5.3 Notes ................................................................................................................. 167 

4.6 [Data Recorder] Window ........................................................................................ 168 

4.6.1 Starting ............................................................................................................... 168 

4.6.2 Screen Structure ................................................................................................ 169 

4.6.3 Outline of Data Recorder Function .................................................................... 171 

4.6.4 Control Panel Window Functions ....................................................................... 172 

4.6.5 Graph Window Structure .................................................................................... 182 

4.6.6 Processing Waveform Data ([File] Menu) .......................................................... 188 

4.6.7 Waveform Display Related Settings ([Option] Menu) ........................................ 193 

4.6.8 Notes .................................................................................................................. 198 

4.7 [Event Viewer] window ........................................................................................... 199 

4.7.1 Starting ............................................................................................................... 199 

4.7.2 Screen Structure ................................................................................................ 200 

4.7.3 Control Panel Window Functions ....................................................................... 202 

4.7.4 Graph Window Functions ................................................................................... 206 

4.7.5 Notes .................................................................................................................. 210 

Chapter 5 Troubleshooting ........................................................................................... 211 

No.1) ............................................................................................................................. 211 

No.2) ............................................................................................................................ 213 

No.3) ............................................................................................................................ 214 

No.4) ............................................................................................................................ 215 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 7/217 2017/09/19 

 

Chapter 1 Outline 

This Chapter describes the features and operating environment of PE-ViewX. 

 

1.1 Features 

PE-ViewX is an integrated development environment for Power Electronics control 

programs. 

This software provides the functions required for control program, such as project 

management, program development and various debugging functions. 

It also generates batch files for compiling automatically according to the source file which 

constitutes a project. 

It also links the library dedicated for PE-Expert4 (hereinafter referred to as the PE library), 

which is specialized in the development of power electronics. 

Using this environment allows the user to easily perform a series of work from editing of a 

source file, compiling, downloading programs and execution to efficient debugging by Wave, 

etc. 

 

- Selection of processor

- Selection of PE library

- Selection of project to be executed

- Explorer: Management of files which 

constitute a project

- Compile: Compiling

- Download: Downloading of programs

- Verify: Verification of programs

- Execute/Stop: Execute/stop

- Inspector: Reading/writing of 

parameters

- Wave: Real time waveform display

- RMemory: Reading of memory

PE-ViewX

Debugging

Project Management

Program 

Development

 

Figure 1: Outline of Functions of Integrated Development Environment PE-ViewX 
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1.2 Operating Environment 

The following chapter shows the recommended operating environment of the PE-ViewX. 

 

● OS 

  Windows 7 operating system (Japanese/English)   (32bit/ 64bit) 

  Windows 10 operating system (Japanese/English)  (64bit) 

 

● Hard Disk 

  Available memory of above 1GB 

 

● Display 

  1366x768 bits and above 

 

● CPU 

Condition Dual core and above 

Operating frequency of above 2.0GHz 

      (At least Intel Core i3 5th generation or equivalent, ie: 

i3-5005U) 

Recommended 

Operating System 

Dual core and above 

Operating frequency of above 2.2GHz 

      (At least Intel Core i5 5th generation or equivalent, ie: 

i5-5200U) 

  

● RAM 

Condition Above 4GB 

Recommended 

Operating System 

Above 8GB 
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1.3 Regarding License 

  ○ DockPanel Suite 

    This package uses DockPanelSuite. The license is MIT, refer to details in license.txt. 

 

○ Open CV 

    Thie package uses OpenCV. There are 3 BSD licenses, refer to the details in LICENSE. 

 

1.4 Regarding Connection to PE-Expert4 

    Please connect Media Converter and PC directly for PE-Expert4 communication. 
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Chapter 2 Screen Structure 

This chapter describes the screen structure of PE-ViewX. 

 

2.1 Outline 

The screen structure of PE-ViewX is as follows: 

   

Sub windows

Main window Menu Tool buttons

 

Figure 2: Screen Structure 

As shown in the above figure, the screen consists of a main window, multiple sub windows, 

menu and tool buttons. 

The following describes each component of the structure. 
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2.2 Main Window 

This is the main window which constitutes PE-ViewX and all sub windows are started from 

the main window. When the main window is closed, PE-ViewX will be closed. 

 

2.3 Menu 

The menu is arranged on the main window. 

 

Figure 3: Menu 

 

The structure of the menu is as follows: 

 

Table 1:  Menu of Main Window 

Main Items Sub Items Functions 

Project Create This is for creating a new project. 

Open This is for opening an existing project. 

Copy This is for copying the project currently selected. 

Properties 
This is for displaying the properties of the project 
currently selected. 

Exit This is for closing PE-ViewX. 

Window Show Window This is for displaying the selected window. 

Reset Window This is for resetting the display of the window. 
Explorer/Inspector/Console will be displayed during 
a reset. 

Close All Window This is for closing all the sub windows. 

Save Current Layout This is for saving current layout 

Load Current Layout This is for opening the layout which has been 
saved previously 

Setting TCP/IP This is for setting the IP address and re-connecting 
to PE-Expert4. 

Editor This is for setting the editor to be used. 
When the source file in Explorer is double-clicked, 
the default editor will start. 

Tool Button This is for setting the tool buttons to be displayed. 

Compiler This is for setting the path of the compiler and 
library. 

Samples This is for setting the path to copy PEOS samples 

External Coupling This is for setting integration with external tools 

Help About PE-ViewX This is for displaying the version information of 
PE-ViewX. 
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See "3.3 Project Settings" for the details of the Project menu. See "3.2 Various Settings" for 

the details of the Setting menu. 

 

Click the Help menu → About PE-ViewX to start the following dialog. 

The version information will be displayed. 

 

 

Figure 4: Version Information 

 

The items displayed are as follows: 

 

Table 2: Version Information Items 

Items Contents 

PE-ViewX The version information of PE-ViewX. 

Serial No. The serial number for license key. 

Licensed Library The version information of PEOS for license key. 

Project Library Version The version of PEOS for current project 

Firmware The version information of the kernel of PE-Expert4. 

Connected Board The boards which are connected to DSP board. 
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2.4 Tool Buttons 

The tool buttons are arranged on the main window. 

 

Figure 5: Tool Buttons 

 

The structure of the tool buttons is as follows. 

Click the Setting menu → Tool Button to toggle display/hide of each tool button. 

 

Table 3: Tool Buttons 

Names Functions 

Compile Executes a compile 

Download Executes a downloading of a program 

Execute Changes a program to the executable state 

Stop Stops the program 

Verify Verifies the downloaded program 

Inspector Starts Inspector 

Memory Starts Memory 

WAVE Starts WAVE 

Data Rec Starts Data Recorder 

PE-Meter ※Starts PE-Meter 

 

See "Chapter 4 Sub Windows" for the details of Inspector/Memory/WAVE/Data Rec. 

 

※ Users will need to purchase an additional METER board for PE-Meter functions. The 

functions include power analysis, torque data, and temperature analysis. Please refer to 

separate manual for PE-Meter 
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2.5 Sub Windows 

The sub windows are started from the main window. 

In PE-ViewX, each of the functions such as WAVE, Inspector is provided in the form of a sub 

window. 

The structure of the sub windows is as follows. 

Click the Window menu → Show Window to display each of the sub windows. 

 

Table 4: Functions of Sub Windows 

Names Functions 

Explorer Displays the files which constitute a project. 

Double-clicking the currently displayed file starts the editor and 

allows you to edit it. 

Memory Displays the contents of the memory of the specified address. 

Inspector Reads/writes the specified parameters. 

WAVE Displays the waveform of the specified parameters in real time. 

Performs an FFT analysis of the read waveform data and displays 

the data. 

Data Recorder Displays waveforms of specified parameters and save the values 

Console Displays the output character string from the compile log and 

PE-Expert4. 

PE-Meter Displays measurements of power, torque, temperature and global 

variables. An additional METER board is necessary for operation. 

Refer to the separate manual for more information 

 

As shown below, sub windows can be arranged inside or outside of the main window. 
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Figure 6: Sub Windows Arranged in Main Window 

Double-clicking or dragging the tab of a sub window allows you to move it outside of the 

main window as shown below: 

 

Figure 7: Sub Window Arranged Outside of Main Window 

Double-click the tab of the main window again to return the sub window into the main 

window. 
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The sub windows can be docked by overlapping the sub windows arranged outside of the 

main window as follows: 

 

 

Figure 8: Docked Sub Windows Arranged Outside 

 

See "Chapter 4 Sub Windows" for the details of the sub windows. 
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Chapter 3 Program Development Procedure 

This Chapter describes the procedure to develop a program using PE-ViewX. 

The following items are described according to an actual development procedure. 

- Starting PE-ViewX 

- Various settings 

- Project settings 

- Edit source files, etc. 

- Compile 

- Download 

- Verify 

- Execute/Stop 

- Debug function 

 

See "Chapter 4 Sub Windows" for the details of the functions of each sub window as 

needed. 

 

3.1 Starting PE-ViewX 

Start PE-ViewX according to the following procedure: 

Connect the license key provided with PE-ViewX to the USB port of a PC. 

The [Hasp key] of SafeNet is used as the license key. 

In order for the PC to recognize the license key, a driver must be installed. 

See the "Installation Instructions Manual" for the installation method of the license key 

driver. 

After the driver is installed, when the license key is connected to the USB port of a PC, the 

license key will be recognized automatically. 

After the license key is recognized, the following will be displayed in the universal serial bus 

controller of the device manager. 

 

 

Figure 9: License Keys Displayed in Device Manager 

 

After the license key is recognized, a red LED will turn ON. 

After the license key is connected, PE-Expert4 will start. 
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See the "Installation Instructions Manual" for starting PE-Expert4. 

Then start the application. 

 

On the Windows menu, click All Programs → Myway Plus → PE-ViewX → PE-ViewX to 

start the application. 

Regarding the starting sequence, be sure to start PE-ViewX after PE-Expert4 is started. 
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3.2 Copy Samples 

PE-ViewX is defaultly stored under [Program Files]. It is necessary to perform PEOS 

installation for operation. In this section, copy the PEOS samples into a desired path. There 

are 2 methods to do so. 

(i) Copy the samples when activation 

When PE-ViewX is first stated, the dialog will appear as follows. Set the directory for PEOS 

samples to be copied. The dialog will only appear when you start PE-ViewX for the first time. 

If [Cancel] is executed, the samples will not be copied. 

 

Figure 10: Select directory for samples to be copied to 

(ii) Copy the samples after opening PE-ViewX 

Open PE-ViewX, Settings → Samples, the dialog will appear as below.  

Set a directory for the samples. 

 

Figure 11: Select directory for samples to be copied to (after opening 

PE-ViewX) 
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Table 5: Items in Sample Copy Dialog 

Items Contents 

Copy Samples Copy samples 

Samples Path Set directory for samples 

Browse Select a direct 

OK Click to copy samples 

Cancel Click to cancel 

 

※For each new version of PEOS installed, the new version of samples will be 

 automatically copied. Click on OK when the above dialog is displayed. 
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3.3 Various Settings 

 

To use PE-ViewX, it is necessary to perform various settings in advance. 

This section describes the following items: 

- IP address 

- Editor 

- Tool buttons 

- Compiler path 

- Sample copy 

- Link to external tools 

 

Once the above items are set, it can be used as they are unless there are changes in the set 

items. For PE-ViewX, different accounts can be used in 1 PC. Refer to the following settings 

 

Table 6: Settings for different accounts 

Association Settings 

Common settings in all accounts ・IP address 

・Compiler path 

Individual setting in each account ・Editor 

・Tool buttons 

・Sample copy 

・Link to external tools 

 

For example, the IP addressis is the same for all accounts. If one user changes IP address, 

the IP of others will also change. 
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3.3.1 IP Address 

PE-Expert4 and PE-ViewX are connected via LAN. 

Therefore, the IP address must be set. 

The setting procedure is as follows: 

 

1) Setting procedure 

Click the Setting menu → TCP/IP to start the following dialog. 

Set the IP address, etc. of PE-Expert4 in this dialog. 

PE-ViewX is connected to the IP address set here. 

 

 

Figure 12: IP Address Setting Dialog 
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The setting items are as follows: 

 

Table 7: Setting Items of IP Address Dialog 

Items Contents 

IP Address IP address of PE-Expert4 

Subnet Mask Subnet mask of PE-Expert4 

Default Gateway Default gateway of PE-Expert4 

Port No. Port number of the board of PE-Expert4 

Reconnect & Set IP Address to 

PE-Expert4 

Enable: Reconnects to PE-Expert4 and writes the set 

contents. 

Disable: Does not reconnect to PE-Expert4 or write. 

Only the IP address saved in PE-ViewX will be 

changed. 

 

Click the OK button to update the set items. 

Clicking the Cancel button will not update the set items. 

 

The values of each address at factory settings are as follows: 

IP Address ： 192.168.1.100 

Subnet Mask ： 255.255.255.0 

Default Gateway ： 192.168.1.101 

Port No. ： 10000 
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2) Notes: 

● The IP address set here becomes enabled when both PE-ViewX and PE-Expert4 are 

restarted the next time. 

● Set the IP address set in PE-ViewX as the IP address to be used on your PC. 

The detailed procedure is as follows: 

 

Click Control Panel of the PC → Network and Sharing Center → Change Adapter 

Settings to open the properties of the applicable network. 

Select Internet Protocol Version 4 (TCPipv4), and confirm the IP address of the PC. 

As shown below, change the values enclosed in red to the same values set in PE-ViewX. 

Set the values enclosed in blue to values different than the values set in PE-ViewX. 

 

Set to the same values 

set in PE-ViewX

Set to values different than 

the values set in PE-ViewX  

Figure 13: Internet Protocol Version 4 (TCPipv4) on PC 

 

When starting up PE-ViewX, there may aniti-vius warning on TCIP/IP port. 

There is no problem in operation, clear the error. 
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3.3.2 Editor 

The editor to edit source files, etc. can be set. The setting procedure is as follows: 

 

Click Setting menu → Editor to start the following dialog. 

In this dialog, set the path of the editor to be used. 

 

 

Figure 14: Editor Settings Dialog 

 

Click the Browse... button to select the editor to be used. 

 

To edit a source file, etc., select the file from the Explorer window described later, and 

double-click to start the editor. 

Click the OK button to update the set items. 

Clicking the Cancel button will not update the set items. 
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3.3.3 Tool Buttons 

The tool buttons displayed on the main window can be set. The setting procedure is as 

follows: 

 

Click the Setting menu → Tool button to start the following dialog. 

In this dialog, select the tool buttons to be displayed. 

 

 

Figure 15: Tool Button Settings Dialog 

 

Click the OK button to update the set items. 

Clicking the Cancel button will not update the set items. 

 

The set contents will be reflected in the main window as shown below: 

 

 

Figure 16: Tool Buttons Displayed on Main Window 
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3.3.4 Compiler Path 

First, it is necessary to set the path of the compiler and the library to be used. The setting 

procedure is as follows: 

 

1) Setting procedure 

Click the Setting menu → Compiler → (Processor name) to start the following dialog. 

In this dialog, set the path of the compiler and the library. 

 

 

Figure 17: Compiler Settings Dialog 
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The settings are as follow: 

 

Table 8: Settings of Compiler Setting Dialog 

Items Contents 

Compiler Path This is for setting the compiler path. 

Specify the [bin] folder. 

The folder where the compiler (cl6x.exe) is saved. 

CSL Path This is for setting the path of CSL (Chip Support Library). 

Specify the [csl] folder. 

The folder where csl.h is saved. 

Mathlib Path This is for setting the mathlib (floating point arithmetic library). 

Specify the [mathlib_xxxx] folder. 

The following shows an example of setting a path when the compiler and library are installed 

in the "c:¥ti" folder. 

 

Compiler Path： 

C: ¥ti¥ccsv5¥tools¥compiler¥c6000_x.x.x¥bin 

CSL Path： 

C: ¥ti¥pdk_C6657_x_x_x_x¥packages¥ti¥csl 

Mathlib Path： 

C: ¥ti¥mathlib_c66x_x_x_x_x 

 

* The "x" represents the version information. 

 

Click the OK button to update the set items. 

Clicking the Cancel button will not update the set items. 

 

2) Notes: 

● Use half-width characters only to set the path of the compiler and library. 

Do not add spaces. 

If a path includes full-width characters or spaces, it cannot be compiled normally. 
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3.3.5 Copy Samples 

The directory to copy samples of PEOS can be selected. Refer to 3.2 Copy Samples for 

more details. 

 

3.3.6 External Coupling 

External coupling refers to introducing .txt files into PE-ViewX. Follow step 1-6 below for 

external coupling. 

 

1) First, enable external coupling. Go to Settings → External Coupling. The following 

dialog is displayed.  

 

 

Figure 18: External Coupling 

 

The following items are in settings. 

 

Table 9: Settings in External Coupling 

Item Contents 

Enable Check: external coupling enabled 

Not check: external coupling not enabled 

My ID PE-View X ID. It is fixed at “1”. 

 

Click the OK button to refresh items. 

Click the Cancel button to cancel any changes. 

Click on Enable button to enable external coupling. 
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2) Command 

The external coupling allows a .txt file to give a command to PE-ViewX.  

Available commands are as follows. 

 

Table 10: List of available command 

Command Content 

fopen Creates and opens the specified file. 

If file already exists, the file is overwritten. 

fopena Creates and opens the specified file. 

If file already exists, opens with append mode. 

fclose Closes the current file. 

read Reads the value of variable and writes it to the current file. 

write Writes the value to variable. 

wait Waits for the specified time. 

until Waits until the value of variable matches the specified value. 

execute Executes user program.  

( Equivalent to click [Execute] button of PE-ViewX) 

stop Stops user program.  

( Equivalent to click [Stop] button of PE-ViewX) 

exit Exits PE-ViewX. 

rename Renames the file. 

wave Sets the WAVE trigger and gets the WAVE data. 

The WAVE data is saved to the current file. 

dos Executes the specified string as MS-DOS Command. 

output Writes the specified string to the current file. 

 

 

There are a few rules for the command.  

○ upper and lower case words must be differentiated 

○ there must be a delimited between parameters 

○ the delimiter can either be in comma, half-width space, tab 

  The delimiter is described as ■ in the following descritption.  
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fopen■Filename: 

- Open specified file.  

- Overite any existing file. 

- Read command value is recorded in the opened file. 

- In case when a folder path is specified, a file will be created.  

- In case when a folder path is not specified, a file will be created in selected project 

folder. 

 

fopena■Filename： 

- Open specified file.  

- The difference between fopen is, if any file is present, a new file will be added instead of 

overwriting it (append mode) 

 

fclose： 

- Close existing file 
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write■variable name■write value■(variable name■write value)： 

- Write the value to the variable. 

- (): specified multiple parameters.  

- A maximum of 200 parameters specified in a line 

- Equivalent to [Write] button in Inspector.  

- For a smooth flow, insert “wait” or “until” command in between”write” commands.  

 

Error occurs in the following condition: 

○ More than 200 parameters in a line. 

○ Specifying a variable name which is not in project. 

○ Writing a decimal value for integer. 

○ “wait” or “until” is not present in between “write” commands. 

 

※ There are two ways to write to the linear array. 

     1)write■array name■#write value#writevalue#write value 

       Writes the value from the top of linear array. 

 

    2)write■array name[Index]■#write value#writevalue#write value 

       Writes the value from the specified index of linear array. 

 

      In write command, one element of the array is equivalent to one variable. 

      So values up to 200 elements can be written. 

 

※When multiple parameters are specified, each data will be written, but not in the same  

  time. The operation is equivalent to [Write] button in [Inspector]. 
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read■variable name(■variable name)： 

- Read specified variable name, and write to the current file. 

- (): specified multiple parameters. 

- A maximum of 200 parameters specified in a line 

- Equivalent to [Read] button in Inspector.  

- For a smooth flow, insert “wait” or “until” command in between”read” commands.  

 

Error occurs in the following condition: 

○ File is not opened. 

○ More than 200 parameters in a line. 

○ Specifying a variable name which is not in project. 

○ “wait” or “until” is not present in between “read” commands. 

 

  ※There are three ways to read from the linear array. 

    1)read■array name 

      Reads the data from all element of linear array. 

 

    2)read■array name[Index] 

      Reads the data from the specified index of linear array. 

 

   3)read■array name[Index]@Length 

      Reads the data from the specified index of linear array for the specified length. 

 

In read command, one element of the array is equivalent to one variable. 

  So values up to 200 elements can be written. 

 

 

※When multiple variable names are specified, each data will be read, but not in the same  

time. The operation is equivalent to [Read] button in [Inspector]. 

 

 

wait■value： 

- wait in specified time, in msec. The value must not be smaller than 200. 
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unti■parameter value： 

- The specified parameter waits to reach the assigned value. 

 

Error occurs in the following condition: 

○ Stating a parameter which is not in project. 

○ Writing a decimal value for integer. 

 

execute： 

- Execute PE-ViewX 

 

stop：   

- Stop PE-ViewX 

 

exit： 

- Exit PE-ViewX 

-  

rename■original file name■new file name: 

- rename file.  

- In case when fold path is not specified, the file of current selected project will be  

renamed.  
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wave■variable name■(variable name)■Type=trigger type■TrgCH=trigger channel 

■Sampling=sampling period■Record=record length■TrgPos=trigger position 

■TrgLevel=trigger level■Edge=trigger edge: 

 

Set WAVE trigger and write the WAVE data to the current file. 

This command is equivalent to [Run] button of WAVE window. 

(): specified multiple variable names. 

A maximum of 16 variable names can be specified in this command. 

 

Error occurs in the following condition: 

○ File is not opened. 

○ Specifying a variable name which is not in project. 

○ “wait” or “until” is not present in between “wave” commands. 

 

※[WAVE] window of PE-ViewX and this command are exclusive. 

  This command cannot be executed while [WAVE] window is running. 

  And [WAVE] window cannot be runned while this command is executing. 

 

Setting items are as follows. 

 

Table 11: List of setting item of wave command 

Item Content 

variable name Specify variable names. 

Up to 16 variables can be specified. 

Type Specify trigger mode 

Auto:   Auto mode 

Single:  Single mode 

TrgCH Specify trigger channel 

1 to 16:  1 to 16 channel 

17    :  ext channel 

Sampling Specify sampling period. (us) 

The setting range is as follows. 

5 to 10000:  variable count is 1 to 8 

10 to 10000: variable count is 9 to 16 
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Record Specify record length. 

The setting range is as follows. 

50 to 524288 

TrgPos Specify trigger position by decimal. (0 to 100%) 

For example, if you specify 50%, pre trigger time and post trigger  

time are equal. 

TrgLevel ○ Specify trigger level by decimal.( -4 billion to 4 billion ) 

○“TrgCH=17” means Ext channel. 

  In this case, trigger level is 0.5.(fixed) 

○ The following suffix can be specified. 

  G:  Giga 

  M:  Mega 

  k:   Kilo 

  m:  Milli 

  u:   Micro 

  n:   Nano 

Edge Specify trigger edge. 

Rise:  Rise Edge 

Fall:   Fall Edge 

 

○ Example is as follows. 

  wave■u■v■w■dwt■Type=Auto■TrgCH=1■Sampling=10■Record=10000■ 

TrgPos=10%■TrgLevel=1.7■Edge=Rise 

 

○ The output is as follows. 

TrgTime(s), u, v, w, dwt 

-0.001000, -7.356457e-002, 9.013488e-001, -8.263211e-001, -8.263211e-001 

-0.000959, -1.980984e-001, 9.475856e-001, -7.491364e-001, -8.263211e-001 

 

○ The format of above output is as follows. 

  TrgTime(s) variable name (variable name) 

    Time      value        (value) 
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    Time value is as follows. 

        Auto mode:   Starts from 0. 

        Single mode:  The index of trigger position is 0. 

 

 

  dos■’XXXX’: 

     Execute any string ( XXXX ) enclosed by single quotation (‘) as MS-DOS Command. 

   

     ○ Enclose with double quotation when specifying the path including space. 

    Example) 

          dos■’cd “C: \Users\1115\folder    1”’ 

 

     ○ Specify “&&” between commands when writing multiple commands. 

       Example) 

       dos■’cd “C: \Users\1115\folder    1” && copy test.txt “.\sub\test.txt”’ 

          Multiple commands stop if the return value of any command is other than 0. 

 

○ Project directory is regarded as current path if you don’t specify the path explicitly. 

 

○ Only the following MS-DOS commands are supported because those are tested. 

  Other MS-DOS commands are not supported, so use them at your own  

responsibility. 

    

  cd/ copy/ del/ dir/ fc/ find/ mkdir/ sort/ pipe function/ redirect function 

/ launching bat file 

 

output■’XXXX’: 

     Write any string( XXXX ) enclosed by single quotation (‘) to the current file. 

    This command can be used as outputting comment. 
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3) Output File 

Method of extracting output file from PE-ViewX and external coupling PE-ViewX: 

Input file to PE-ViewX: InputToViewX_1.txt 

Output file from PE-ViewX: OutputFromViewX_1.txt 

 

Input or output files are objects from selected project folder. 

 

 

 

 

         

 

 

 

 

 

 

 

 

 

 

Figure 19: File Input/Output 

 

The explanation of the above is as follow: 

 

① The external tool will generate a temporary file with commands to PE-ViewX. The 

commands include opening and closing of files, reading and writing of variables. 

② When the temporary file is created, it will be named as “InputToViewX_1.txt”. 

③ The contents will be loaded after “InputToViewX_1.txt” is named in project folder. The 

temporary file will be deleted. 

④ PE-ViewX executes the commands in “InputToViewX_1.txt”. the following commands 

need to be present in the file:  

 

fopen “temp file name” 

Arbitrary commands 

fclose 

PE-ViewX 

External Coupling 

[External Tool] 

① Write temp file 

② Name as “InputToViewX_1.txt” 

 

[PE-ViewX] 

③ Load “InputToViewX_1.txt”, delete 

[PE-ViewX] 

④ Write temp file 

⑤ Name as “OutputFromViewX_1.txt” 

 

[External Tool] 

⑥ Load “OutputFromViewX_1.txt”, delete 
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rename “temp file name” OutputFromViewX_1.txt 

        

At the point of executing fclose, temporary file creation is completed. 

           

⑤ At the point of executing rename, temporary file will be renamed to 

“OutputFromViewX_1.txt”. When all the commands are executed, 

“OutputFromViewX_1.txt” will be created in project folder.  

⑥ The external tool also monitors any changes to the file.  

And the external tool loads after “OutputFromViewX_1.txt” is generated. 

After that, “OutputFromViewX_1.txt” needs to be deleted by the external tool. 

The external tool determines the next commands based on “OutputFromViewX_1.txt” 

and issue a command to PE-ViewX. (returns to ①) 
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4) Sample 

 

The following shows a sample of commands in PE-ViewX. The contents are executed in 

PE-ViewX.  

 

fopen TmpOutputFromViewX_1.txt 

execute 

write Start_Flg 1 

wait 500 

read iw uw vw 

fclose 

rename TmpOutputFromViewX_1.txt OutputFromViewX_1.txt 

 

The sample follows these operations. 

① Open temporary file “TmpOutputFromViewX_1.txt” 

② Execute user program 

③ Write “1” to parameter “Start_Flg” 

④ Wait 500msec 

⑤ Read parameters “iw, uw, vw” from user program. The data will be recorded to 

temporary file 

⑥ Close temporary file 

⑦ Rename temporary file to output file “OutputFromViewX_1.txt” to external tool 

 

5) Time Out Processing 

In case of no response from PE-ViewX after a certain time period, the external tool can 

perform timeout processing. The external tool will send a new file “InputToViewX_1.txt” to 

PE-ViewX. When there is a new file sent to PE-ViewX, the presently executed commands 

will be terminated, and executed the commands from the new “InputToViewX_1.txt”. 

 

6) Error Porcessing  

If an error occurs during command processing on PE-ViewX, the error contents will be 

displayed in project folder as “error.txt”. When the external tool detected “error.txt”, the errors 

are processed and the file will be deleted. 

 

7) Sample Files from Excel 

The example below shows an external coupling with an excel spreadsheet. It is created with 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 41/217 2017/09/19 

 

similarities to Inspector. Excel will first create a file, PE-ViewX will read the file and display 

acquired data. The operation is in continuous mode, “Start” to begin and “Stop” to stop.  

 

- Write a value to [D7] StartFlag 

- Read [D10] StartFlag 

- Read [D11] Counter 

 

“TestErr” is for error commands, “error.txt” will be created. 

 

 

Figure 20: Sample File in Excel 

 

※ Before using Excel files, perform the following.Excel 

A) For this sample, use “SampleExcelVBA.xlsm” which is present in 

“test_external_coupling.prj” for Download and Execute in PE-ViewX.  

B) Set path for project folder in [D2]. 
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3.3.7 Offset of timeout 

The offset of communication timeout for PE-ViewX and PE-Expert4 can be set separately. 

Communication timeout occurs in the following cases. 

 

[PE-ViewX] 

PE-ViewX issues polling command every few seconds. 

And PE-ViewX issues data request command when executing WAVE and Inspector, etc. 

Communication timeout of PE-ViewX occurs when those commands have no response from  

PE-Expert4. 

 

[PE-Expert4] 

PE-Expert4 waits for any command from PE-ViewX. 

Communication timeout of PE-Exert4 occurs when no command is received from PE-ViewX 

for few seconds. 

 

By setting offset of timeout, time until timeout occurs is extended. 

Offset value of PE-Expert4 is saved to Flash ROM, so this value is retained even when  

turning off PE-Expert4. 

 

[Settings] menu > Click [Offset of Timeout] to display the below dialog 

 

 

Figure 21: [Offset of Communication Timeout] Dialog 

 

Settings items are as follows. 

Table 12: List of settings items 

Items Context 

PE-ViewX Set the offset value of PE-ViewX. 

Value can be set 0 to 20(s). 

PE-Expert4 Set the offset value of PE-Expert4. 
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Value can be set 0 to 20(s). 

 

3.3.8 Data Table 

Data Table function downloads data table defined by *.csv file to RAM of PE-Expert4. 

RAM address is 0x81900000 to 0x81ffffff. ( Up to 7M byte ) 

User program can refer to the data table like torque map etc. 

Data table is downloaded only to RAM, so data is cleared when turning off PE-Expert4. 

 

[Settings] menu > Click [Data table] to display the below dialog. 

 

Figure 22: [Data Table Settings] Dialog 

 

Figure 23: List of settings items of data table 

Items Content 

Type Specify the data format of data table. 

Data table is downloaded with little endian. 

The format can be selected from the following. 

 

Unsinged Integer X Byte: Values separated by comma are 

                       interpreted as unsigned decimal 

                       number. 

Signed Interger X Byte:  Values separated by comma are 

                       interpreted as signed decimal 

                       number. 

Hexadecimal X Byte:    Values separated by comma are 

                       interpreted as hexadecimal                        

number. 

Float 4 Byte:            Values separated by comma are 
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                       interpreted as single-precision 

floating-point number. 

If no value is specified between commas, it is interpreted as 

0. 

Path Specify *.csv file of data table path. 
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3.4 Project Settings 

This section describes the following items for setting a project. 

- Create 

- Open 

- Copy 

- Properties 

 

3.4.1 Create 

1) How to create a new project 

Click the Project menu → Create to start the following dialog. 

To create a new project, set the necessary information in this dialog. 

 

 

Figure 24: Create Project Dialog 
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The setting items are as follows: 

 

Table 13: Setting Items of Create Project Dialog 

Items Contents 

Type Selects the processor. 

Location Sets the path where the project is to be created. 

Directly enter the path, or select from the Browse... button. 

Name Sets the project name. 

Library Version Selects the version of the PE library to be linked. 

Stop Confirm Enable: When the Stop button is clicked, a confirmation message 

on whether to stop the program will be displayed. 

Disable: When the Stop button is clicked, the program will stop 

without displaying any message. 

  

Click the OK button to create a new project. 

Click the Cancel button to cancel the creation. 
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2) Example of creating a new project 

As a reference, create a new project with the following settings. 

Type  ： c6657 

Location ： c:¥MywayPlus¥project¥sample_1 

Name ： sample_1 

Stop Confirm ： Disable 

 

 

Figure 25: Create Project Dialog (sample_1 Project) 

 

After the items are set, click the OK button. 

A new sample_1 project will be created. 

The following files will be created automatically in the sample_1 folder. 

 

Table 14: Files Created Automatically 

File Names Contents 

sample_1.prj The project file for saving the project information. 

sample_1.c The source file where the MW_main() function is described. 

sample_1.cmd The linker script file used when linking. 

linker_image.rmd The configuration file used to create download files. 
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As shown below, the file structure of a newly created project will be displayed in the 

Explorer window. 

 

Figure 26: sample_1 project displayed in Explorer Window 

 

As shown in the above figure, the PE library required for compiling, and CSL library, etc. are 

linked by default. 

Similarly, header files of the PE library and CSL, etc., are also referenced by default. 

In this step, clicking Compile of the tool buttons will display the compile log in the Console 

window as shown below. 

It shows that the compiling was successful. 
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Figure 27: Compile Log displayed in Console Window 

 

Do not modify the sample_1.prj/ linker_image.rmd file during development. 

The sample_1.cmd file will automatically be updated each time a compile is executed. 

For cases where a different compilation option is used, set the automatic update function of 

the batch file to disable, then manually modify the sample_1.cmd file. 

See "Chapter 4 Sub Windows" for how to disable the automatic updating function of a batch 

file. 
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3.4.2 Open 

Click the Project menu → Open to open an existing project. 

As shown below, the Select File dialog will be displayed. Select the project file (*.prj) of the 

project to be opened. 

In the following example, a sample [tutor] project included in the PE library is opened. 

(C:¥MywayPlus¥PE-ViewXaa¥PEOS¥c6657¥a_bb¥sample¥tutor) 

aa… version of PE-ViewX 

a_bb… version of PEOS 

 

 

Figure 28: Selection of Tutor Project 
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When the [tutor] project is opened, the following screen will be displayed. 

 

 

Figure 29: Completion of Tutor Project Selection 
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3.4.3 Copy 

Click the Project menu → Copy to start the following dialog. 

To copy the currently selected project, select the path of the copying destination in this 

dialog. 

 

 

Figure 30: Copy Dialog 

 

The settings are as follow: 

 

Table 15: Setting Items of Copy Dialog 

Items Contents 

Location Set the path of the copy destination of the project. 

Directly enter the path, or select from the Browse... button. 

 

Click the OK button to copy a new project. 

Click the Cancel button to cancel the creation. 
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3.4.4 Properties 

Click the Project menu → Properties to start the following dialog. 

The properties of the currently selected project will be displayed. 

 

Figure 31: Properties Dialog 

 

The settings are as follow: 

 

Table 16: Display Items of Properties Dialog 

Items Contents 

Type Displays the processor 

Location Displays the project path 

Name Displays the project name 

Library Version Displays the version of the linked PE library. 

It can be changed. 

Stop Confirm Enable: When the Stop button is clicked, a confirmation message 

on whether to stop the program will be displayed. 

Disable: When the Stop button is clicked, the program will stop 

without displaying any message. 

It can be changed. 

 

Click the OK button to reflect the changes. 

Click the Cancel button to cancel the creation. 
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3.5 Editing Source Files, Etc. 

This section describes the editing method of a source file, etc. 

The file which constitutes a project can be managed from the Explorer window. 

 

 

Figure 32: Explorer Window 

 

The structure of the Explorer window is as follows: 

 

Table 17: Display Items of Explorer Window 

Items Contents 

Project Root directory. 

Displays the following items which constitute a project. 

Source Displays the source file. 

Include Displays the path of a header file, and the header file in the list. 

Object/Library Displays the library to be linked and the object file. 

Configuration Displays the batch file and linker script file used for compiling. 

Mode Displays the execution status of the project. 
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3.5.1 Editing Source Files 

As shown in the above figure, all the files which constitute a project are displayed in the 

Explorer window. 

The source file of a project is displayed in Source. 

Double-clicking the Source file starts the editor set by clicking the Setting menu → Editor 

and allows the source file to be edited. 

 

3.5.2 Adding Source Files 

There are two methods for adding source files. 

Both methods are executed from the context menu of Source. 

 

 

Figure 33: Source Context Menu 

 

(i) How to add from Add File 

Right-click [Source] to display the context menu. 

Click Add File to start the file dialog. 

Select the file to be added to a project in this dialog. The file will be added as a source file. 

The file of other folders besides the project can also be added as a source file. 

 

(ii) How to add from Update 

Right-click [Source] to display the context menu. 

Select Update to add all c source files (*.c) existing in the project folder to the project as 

source files. 
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3.5.3 Adding Reference Destination of Header Files 

To add the reference destination of a header file, follow the procedure below: 

Right-click Include → select Add Folder → add the folder of the reference destination from 

the folder dialog. 

 

 

Figure 34: Include Context Menu 

 

See "Chapter 4 Sub Windows" for the details of the Explorer window. 
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3.6 Compiling 

This section describes how execute a compile. 

Click Compile of the tool buttons to execute a Compile. 

All the files are recompiled each time a compile is performed. 

The compile log is displayed on the Console window. 

Even while the Console window is closed, when Compile is executed, the Console window 

starts automatically, and displays the log. 

 

When the compiling is successful, "Compile OK" will be displayed as follows: 

 

 

Figure 35: Display When Compile is Successful 
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When an error occurs, "Compile Failure" will be displayed as follows. 

The location of the error will also be displayed. Solve the problem, and then execute a 

compile again. 

 

 

Figure 36: Compilation Error Display 

 

* During a compile, the compiling is performed in the EABI mode of the c6000 compiler. 

The following types are used in the EABI mode. 

 

Table 18: EABI Mode Type 

 

 

 

 

Types Size 

char 8bit 

unsigned char 8bit 

short 16bit 

unsigned short 16bit 

int 32bit 

unsigned int 32bit 

long 32bit 

unsigned long 32bit 

float 32bit 

double 64bit 

pointer 32bit 

enum 32bit 
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3.7 Downloading 

3.7.1 Executing Download 

This section describes how to execute a download. 

On downloading a developed program, it is written to PE-Expert4. 

It allows the developed program to be executed on PE-Expert4. 

Click Download of the tool buttons to execute a download. 

 

The target.btbl file is used for downloading. 

This is a file of the program code and data, and is created during a compile. 

During a download, the following progress dialog will be displayed. 

 

 

Figure 37: Download Progress Display 

 

This progress status shows how much download data has been transmitted to PE-Expert4. 

The download can be cancelled by clicking the Cancel button unless the download has 

already been completed. 

When the progress status reaches 100%, "Flash Writing" and "System Resetting" will be 

displayed. 

While these items are displayed, writing of the Flash rom to PE-Expert4 and resetting of the 

system are being performed, so the download cannot be cancelled. The Cancel button will 

be in the disabled state. 

Do not turn OFF the power supply of PE-Expert4 during this period. 

 

When the download is completed, the dialog closes automatically. “Download Succeeded” 

will be displayed on the Console. If [Inspector]/[WAVE]/[Data Recorder] is opened before 

download, the new values will be refreshed in the windows. 

The Console will display: 
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“Variable Information in Inspector Updated” 

“Variable Information in WAVE Updated” 

“Variable Information in Data Recorder Updated” 

 

After the download is completed, the program can be executed without restarting. 

 

3.7.2 Notes 

● Note that the following functions will stop automatically during a download. 

- If Auto Refresh of Inspector is enabled, it becomes disabled. However, the setting returns 

to enable after the download is completed. 

- While Wave is running, the status changes to Stop. 

● During program execution, download cannot be executed. 

● During data recording, download cannot be executed. 
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3.8 Verify 

3.8.1 Executing Verify 

This section describes how to execute the verification. 

Verify is for confirming whether the program and data written in PE-Expert4 conform to the 

contents of the target.btbl file in the project folder. 

Click Verify of the tool buttons to execute the verification. 

During the verification, the following progress dialog will be displayed. 

 

 

Figure 38: Verification Progress Display 

 

This progress status shows how much data for verification has been transmitted to 

PE-Expert4. The download can be cancelled by clicking the Cancel button unless the 

verification has not been completed. 

After the verification is completed, the execution results will be displayed. 

When the verification is successful, the following dialog will be displayed. 

 

 

Figure 39: Display When Verification is Successful 

 

 

 

 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 62/217 2017/09/19 

 

When an error occurs, the following dialog will be displayed. 

 

 

Figure 40: Verification Error Display 

 

3.8.2 Notes 

● Note that the following functions will stop automatically during verify. 

- If Auto Refresh of Inspector is enabled, it becomes disabled. However, the setting returns 

to enable after verify is completed. 

- While Wave is running, the status changes to Stop. 

● During program execution, verify cannot be executed. 

● During data recording, verify cannot be executed. 
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3.9 Execute/Stop 

3.9.1 Execute/Stop Functions 

This section describes the function of Execute/Stop. 

Click Execute of the tool buttons to execute the program downloaded to PE-Expert4. Click 

Stop to stop the program. 

The program is executed from the beginning each time Execute is clicked. 

The execution status of the program is displayed in Mode of the Explorer window as shown 

below: 

 

 

Figure 41: Running Status Display 

 

The contents displayed in Mode are as follows: 

 

Table 19: Mode Display Contents 

  Mode Contents Display 

Monitor Mode The user program stopped.  

Target Program Running The user program is running. The 

display will be blinking. 

 

Disconnected The LAN is not connected.  

Cannot Connect No response from PE-Expert4.  
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3.9.2 Notes 

● If FPGA board is used in PE-Expert4, an internal communication error may occur. In 

Mode, “EMIF ERROR has occurred” will be displayed. Refer to FPGA manual for further 

details 

● PE-Expert4 is working on stand alone mode. 

Standalone mode – PE-Expert4 executes program which has been saved into the Flash 

rom. Program execution begins with Execute. To perform this mode, OFF bit2 of SW9 on 

MWPE4-C6657. Refer to “4.9 Standalone Mode” for more details. 
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3.10 Debug Functions 

This section describes the debug functions. 

The following functions are provided in PE-ViewX to debug control programs. 

Each function is provided in the form of a sub window. 

 

Table 20: Debug Functions 

Names Functions 

Memory Displays the contents of the memory of the specified address. 

Inspector Reads/writes the specified parameters. 

WAVE Displays the waveform of the specified parameters in real time. 

Performs an FFT analysis of the read waveform data and displays the 

data. 

Data Recorder Displays the waveform of the specified parameters.  

Save the data of parameters 

 

There are two methods to debug this function: 

- Start the applicable sub window from the tool button. 

- Click the Window menu → Display Window to start the applicable sub window. 

 

For Memory and Inspector, up to three sub windows can be started at once. 

See "Chapter 4 Sub Windows" for the details of the functions of each sub window. 
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Chapter 4 Sub Windows 

This chapter describes the functions of the sub windows which constitute PE-ViewX. 

 

4.1 Explorer Window 

The Explorer window is for managing the files which constitute a project. 

Addition, deleting, editing, etc. of source files can be performed from this window. 

Click the Window menu → Display Window → Explorer to display the following window. 

 

Figure 42: Explorer Window 

 

Table 21: Display Items of Explorer Window 

Items Contents 

Project Root directory which displays the following items from a project. 

Source Displays the source file. 

Include Displays the path of a header file, and the header file in the list. 

Object/Library Displays the library to be linked and the object file. 

Configuration Displays the batch file and linker script file used for compiling. 

Mode Displays the execution status of the project. 

 

Double-clicking the files in Source, Include and Configuration starts the files from editor, and 

allows them to be edited. 

The following describes each item of the Explorer window. 
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4.1.1 Project 

This is the root directory of a project. 

While the cursor is placed on the project, the following operations can be performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 43: Project Context Menu 

 

The items of the context menu are as follow: 

 

Table 22: Project Context Menu 

Items Contents 

Delete Project Deletes the project from the Explorer window. 

This process is just for closing from PE-ViewX, and there is no effect on 

the file system. 

Properties Displays the properties dialog. 

 

●Delete key 

This key executes the same process as Delete Project of the context menu. 
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4.1.2 Source 

This function displays the source files which constitute a project. 

The source file and subfolder can be displayed in Source as shown below: 

 

 

Figure 44: Source File and Subfolder 

 

[When the cursor is placed on Source] 

While the cursor is placed on Source, the following operations can be performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 45: Source Context Menu 
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The items of the context menu are as follow: 

 

Table 23: Source Context Menu 

Items Contents 

Add File Adds a source file to a project. 

The file dialog will be displayed. The following processes can be 

performed from this dialog. 

- Select an existing source file to add to a project. 

- Create a new source file to add to a project. 

Follow the procedure below: 

Select Create in the file dialog → select Text Document → select the 

newly created text file to rename the source file (*.c/*.asm) → place 

the cursor on the source file and right-click to add to a project. 

Add Folder Adds a subfolder to Source. 

This folder is a virtual folder, and is not created in the file system. 

Update Adds all the source files (*.c/*.asm files) in the project folder to a project. 
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[When the cursor is placed on a source file in Source] 

While the cursor is placed on a source file in Source, the following operation can be 

performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 46: Context Menu of Source File in Source 

 

The items of the context menu are as follow: 

 

Table 24: Source File Context Menu 

Item Contents 

Delete File Deletes a source file from a project. 

When deleting, whether to delete from a project or the file system can be 

selected. 

 

●Delete key 

This key executes the same process as Delete File of the context menu. 
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[When the cursor is placed on a subfolder in Source] 

While the cursor is placed on a subfolder in Source, the following operation can be 

performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 47: Context Menu of Subfolder in Source 

 

The items of the context menu are as follow: 

 

Table 25: Subfolder Context Menu 

Items Contents 

Delete Folder Deletes a subfolder from a project. 

During this process, the source file in the subfolder will also be 

deleted from a project. 

There is no effect on the file system. 

Add Folder Adds additional subfolders to a subfolder. 

This folder is a virtual folder, and is not created in the file system. 

Add File Adds source files to a subfolder. 

 

●Delete key 

This key executes the same process as Delete Folder of the context menu. 
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4.1.2 Include 

This function displays the header path of the project being referred to. The following is 

displayed. 

 

 

Figure 48: Structure of Include 

 

The contents of the environment variables displayed in the above figure are as follows: 

 

Table 26: Contents of Environment Variables 

Environment 

Variables 

Contents 

PROJECT_PATH Refers to the project path currently selected. 

PEOS_PATH Refers to path of the PE library in which the currently selected 

project is linked. 

COMPILER_PATH Refers to the path of the "Compiler Path" set by clicking the 

Setting menu → Compiler → (Processor name). 

CSL_PATH Refers to the path of the "CSL Path" set by clicking the Setting 

menu → Compiler → (Processor name). 

MATHLIB_PATH Refers to the path of the "Mathlib Path" set by clicking the Setting 

menu → Compiler → (Processor name). 
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As shown below, clicking the folder of the header path displays all the header files (*.h) in 

the folder. 

Double-clicking the header file starts the editor and allows it to be edited. 

 

 

Figure 49: Header File in Header Path 
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[When the cursor is placed on Include] 

While the cursor is placed on Include, the following operations can be performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 50: Include Context Menu 

 

The items of the context menu are as follows: 

 

Figure 51: Include Context Menu 

Items Contents 

Add Folder Adds the header path of the project to be referred to. 

Update Updates the display of the header file in the header path. 

Displays all the header files (*.h) in the header path. 
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[When the cursor is placed on the header path in Include] 

While the cursor is placed on the header path in Include, the following operations can be 

performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 52: Context Menu of Header Path in Include 

 

The items of the context menu are as follow: 

 

Table 27: Header Path Context Menu 

Items Contents 

Delete Folder Deletes the header path from a project. 

There is no effect on the file system. 

Raise Raises the priority of the reference, when multiple header paths are 

registered. 

Lower Lowers the priority of the reference, when multiple header paths are 

registered. 

 

●Delete key 

This key executes the same process as Delete Folder of the context menu. 
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4.1.3 Object/Library 

This function displays the object files and library files linked to a project. The following is 

displayed. 

 

 

Figure 53: Structure of Object/Library 

 

The contents of the environment variables displayed in the above figure are as follows: 

 

Table 28: Contents of Environment Variables 

Environment Variables Contents 

PEOS_PATH Refers to path of the PE library in which the currently selected 

project is linked. 

COMPILER_PATH Refers to the path of the "Compiler Path" set by clicking the 

Setting menu → Compiler → (Processor name). 

CSL_PATH Refers to the path of the "CSL Path" set by clicking the Setting 

menu → Compiler → (Processor name). 

MATHLIB_PATH Refers to the path of the "Mathlib Path" set by clicking the 

Setting menu → Compiler → (Processor name). 
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[When the cursor is placed on Object/Library] 

While the cursor is placed on Object/Library, the following operation can be performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 54: Context Menu of Object/Library 

 

The items of the context menu are as follows: 

 

Table 29: Object/Library Context Menu 

Items Contents 

Add File Adds object files and library files to be linked to a project. 
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[When the cursor is placed on a file in Object/Library] 

While the cursor is placed on a file in Object/Library, the following operations can be 

performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 55: Context Menu of File in Object/Library 

 

The items of the context menu are as follow: 

 

Table 30: Context Menu of File in Object/Library 

Items Contents 

Delete File Deletes the object files and library files linked to a project. 

There is no effect on the file system. 

Raise Raises the priority of the link, when multiple files are registered. 

Lower Lowers the priority of the link, when multiple files are registered. 

 

●Delete key 

This key executes the same process as Delete Folder of the context menu. 
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4.1.3 Configuration 

This function displays the linker script files and batch files for compiling that are used during 

a compile. The following is displayed. 

 

Figure 56: Structure of Configuration 

 

The contents of the files displayed in the above figure are as follows: 

 

Table 31: Contents of Configuration File 

File Names Contents 

*.bat Batch file for compile 

*.cmd Linker script file 

 

[When the cursor is placed on Configuration] 

While the cursor is placed on Configuration, the following operation can be performed. 

 

●Context menu 

Right-click to display the following context menu. 

 

Figure 57: Configuration Context Menu 

 

The items of the context menu are as follows: 

Table 32: Configuration Context Menu 

Items Contents 

Create batch file Enable: Automatically creates a batch file for each execution of a 

compile based on the current file structure. 

Disable: Does not automatically create a batch file during the 

execution of a compile. The contents of a batch file can 

be customized and compiled accordingly. 
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4.1.4 Mode 

This function displays the execution status of a project. The following is displayed. 

 

 

Figure 58: Mode Structure 

 

The contents displayed in Mode are as follows: 

 

Table 33: Mode Display Contents 

  Mode Contents Display 

Monitor Mode The user program is stopped.  

Target Program Running The user program is running.  

Disconnected The LAN is not connected.  

Cannot Connect No response from PE-Expert4.  

 

●Context menu 

Right-click to display the following context menu. 

 

 

Figure 59: Mode Context Menu 

 

The items of the context menu are as follows: 

 

Table 34: Mode Context Menu 

Items Contents 

Connect LAN connection. When status is [Disconnected] / [Cannot Connect], click on 

it to enable LAN connection. 

Disconnect LAN disconnection. When status is [Monitor Mode] / [Target Program 

Running], click on it to disable LAN connection 
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4.2 Console Window 

The Console window displays the character string output from the compile log and 

PE-Expert4. 

There are two methods to display this window. 

- Click the Window menu → Display Window → Console to display the following window. 

- During the execution of Compile. 

 

 

Figure 60: Console Window 

 

The compile log will be displayed as shown below: 

 

 

Figure 61: Compile Log Display 
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The following operations can be performed in the Console window. 

 

● Context menu 

Right-click while the cursor is placed on the Console window to display the following context 

menu. 

 

Figure 62: Context Menu of Console Window 

 

The items of the context menu are as follows: 

 

Table 35: Context Menu of Console Window 

Items Contents 

Select All Select all currently displayed character strings. 

Copy Copies the selected character string to a clipboard. 

Clear Clears all the character strings currently displayed. 

Show Message Sets the message to display or hide. 

When a check mark is entered, the message will be displayed, and 

when not entered, the message will not be displayed. 

The following items can be set: 

- Compiler log 

- Character string output from PE-Expert4 
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● Searching character strings 

The specified character string can be searched from the character string displayed on the 

Console window. 

Character strings can be searched from the following locations. 

 

 

Figure 63: Searching Character Strings 

 

The search function of character strings is as follows: 

 

Table 36: Searching Character Strings 

Items Contents 

Text box This box is for entering the character string to be searched. 

↑ Searches character strings upwards. 

↓ Searches character strings downwards. 

 

When there is a matched character string in the search results, the applicable character 

string is highlighted as shown below. 

 

 

Figure 64: Search Results Display 

 

● Changing font size 

  Font size can be changed as shown below. 

 

Figure 65: Setting font size 
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4.3 Inspector Window 

The Inspector window is for reading/writing the specified variables. 

There are two methods to display this window. 

- Click the Window menu → Show Window → Inspector 

- Click Inspector of the tool buttons. 

 

The following screen will be displayed. 

 

 

Figure 66: Inspector Window 

 

Up to three Inspector windows can be displayed at once. 
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4.3.1 Structure of Fields 

The Inspector window consists of the following fields. 

 

Table 37: Structure of Inspector Window Fields 

Fields Contents 

Comment(1) For entering comments 

Address For entering a variable name or address. 

●Entry of variable name or address 

   [Entry of variable name] 

Directly enter a variable name, or double-click to select from  

the variable list. 

[Entry of address] 

Enter in a hexadecimal expression like "0x..." 

 

●Pointer variable 

   Read only. 

   [Entry of pointer variable name] 

        Enter a pointer variable name, then address which pointer 

        variable holds is displayed. 

   [Enter of asterisk(*) + pointer variable name] 

         Enter asterisk(*) + pointer variable name, then data which 

         pointer variable points to is displayed. 

 

●Array 

   The following type of linear array can be entered. 

  char/ unsigned char/ short/ unsigned short/ int/ unsigned int/ 

  long/ unsigned long/ float/ double 

   

  There are three ways to enter a linear aray. 

  (1)Array name only 

     Displayed all elements. 

     Example) 

              c_Array 
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Fields Contents 

(2)Array name[index] 

      Displayed from element specified by index. 

      Example) 

              c_Array[3] 

 

   (3)Array name[index]@length 

      Displayed from element specified by index to length. 

      Example) 

              c_Array[3]@5 

E (Read Enable) For setting the read process to enable/disable. 

The item set to enable is applicable for reading. 

 

Enable:  is displayed 

Disable: Blank 

Read Value Displays the read value. 

Write Enable For setting the read process to enable/disable. 

The item set to enable is applicable for writing. 

 

Enable:  is displayed 

Disable: Blank 

 

※ For pointer variable in [Address], [Write] will not be carried out 

when enabled. 

Write Value For entering the value to be written. 

The features of this field are as follows: 

- Displays the written value in red at the time of entry. 

Then, when the writing is executed by the Write button, the value will 

be displayed in black. 

- The values which can be entered in this field are linked to the 

Format field. 

For example, enter 0 to 1 when using binary numbers, and 0 to f 

when using hexadecimal numbers. 

- When a decimal number is used in the Format field, entry of 

exponential expression is also acceptable. 

Type Displays the types of variables. 
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Fields Contents 

The following variable types can be displayed. 

 

char: char type 

uchar: unsigned char type 

short: short type 

ushort: unsigned short type 

int: int type / long type 

uint: unsigned int type / unsigned long type 

float: float type 

double: double type 

enum: enum type 

char＊: char type pointer  

uchar＊： unsigned char type pointer 

short＊： short type pointer 

ushort＊： unsigned short type pointer 

int＊： int type / long type pointer 

uint＊： unsigned int type / unsigned long type pointer 

float＊： float type pointer 

double＊： double type pointer (for reference) 

enum＊： enum type pointer 

 

Note that both the int type / long type are displayed as int. 

Similarly, both the unsigned int type / unsigned long type are 

displayed as uint. 

When an address is specified, it is displayed as an int type. 

Format For selecting the format to be displayed. 

The format can be selected from the following: 

 

Bin    : Binary number expression 

Dec(S) : Signed decimal number expression 

Dec(U) : Unsigned decimal number expression 

Hex   : Hexadecimal number expression 

 

Note that a floating point expression is common to both 

Dec(S)/Dec(U) for a floating point format (float/double). 
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Fields Contents 

Comment(2) For entering comments 
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The window is displayed is as follows: 

 

Figure 67: Example of Variable Display 

 

The position of the fields can be moved by dragging. 

For example, drag Address item to move it to the following position. 

 

 

Figure 68: Example of Moved Address Field 

 

  Array is displayed as follows. 

 

Figure 69: display of array 
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4.3.2 Reading/Writing Variables 

This section describes how to read/write the variables. 

Follow the procedure below.  

The target variables of the reading/writing are the global variables only. 

 

1) Setting the variable name in the Address field 

  There are three setting methods as shown below: 

 

(i) When selecting a variable name 

Place the mouse cursor in a cell of the Address field and double-click. The list of 

variables used for the program selected as the target will be displayed. Select the variable 

to be read/write. 

  In this state, the variable can be selected by the following two methods. 

- Select a variable name with the mouse. 

- When the first character of a variable name is entered, the applicable variable name will 

be selected automatically. 

 

Figure 70: Variable Name List Display 

 

(ii) When entering a variable name 

Place the mouse cursor in a cell of the Address field, and type in the variable name. 

After entering, press the Enter key or move the cursor to set the variable name. 

 

Figure 71: Variable Name Text Entry 
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(iii) When entering an address 

Place the mouse cursor in a cell of the Address field, and type in the address. 

Specify "0x..." in a hexadecimal number expression. 

After entering, press the Enter key or move the cursor to set the address. 

 

 

Figure 72: Address Text Entry 

 

2) Enabling Read/Write 

○ Read 

Click the E field on the left side of Read Enable to display . 

Note that the variables of rows without the  will not be applicable for reading. 

 

 

Figure 73: Enabling Reading 

 

○ Write 

Click the E field on the left side of Write Enable to display . 

Note that the variables of rows without the  will not be applicable for writing. 

 

 

Figure 74: Enabling Writing 
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3) Executing Read/Write 

○ Read 

Click the Read button. 

When executing reading at a regular interval, select the check box of Auto Refresh 

located on the lower portion of the screen. 

 

 

Figure 75: Execution of Reading 

 

 

Figure 76: Reading Completed State 

 

○ Write 

Click the mouse in the Write Value field, and enter the value to be written. 

When the value is entered, the value in the Write Value field will be displayed in red. 

 

 

Figure 77: Status of Entered Value to be Written 

 

Then, click the Write button. 

When writing is executed, the value will change to black. 

 

 

Figure 78: Execution of Writing 

 

 

Figure 79: Writing Completed State 
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4.3.3 Changing Display Format 

The display format of the read/written values can be changed. 

The format can be selected from a binary number, signed decimal number, unsigned 

decimal number or a hexadecimal number. 

When a signed decimal number / unsigned decimal number are selected, the variable of a  

floating point format (float/double) will be displayed in an exponential expression. 

To change the display, double-click the Format field to display the list as shown below: 

 

 

Figure 80: Changing Display Format 

 

Both the Read Value / Write Value follow the contents of the Format field. 

For example, when "100" is displayed, the value becomes as follows: 

- When Bin is selected  : "100" of a binary number 

- When Dec(S)/Dec(U) is selected : "100" of a decimal number 

- When Hex is selected  : "100" of a hexadecimal number 

 

4.3.4 Menu 

The menu is arranged in the Inspector window. 

 

 

Figure 81: Menu 

The structure of the menu is as follows: 

 

Table 38: Inspector Window Menu 

Main Items Sub Items Functions 

File Load Configuration File Reproduces the saved setting. 

Save Configuration File Saves the current setting. 

Option Interval Time When Auto Refresh is set to enable, the interval 
for  reading automatically can be selected from 
the following: 
0.5 sec., 1 sec., 2 sec., 3 sec., 4 sec., 5 sec. 

Display Item For selecting the field to be displayed in the 
Inspector window. 
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4.3.5 Context Menu 

Right-click to display the following context menu. 

 

 

Figure 82: Context Menu 

 

The items of the context menu are as follows: 

 

Table 39: Inspector Window Context Menu 

Items Contents 

Set All Format Collectively changes the display format of all the registered 

variables. 

The format can be selected from the following: 

Bin: Binary number 

Dec(S): Signed decimal number 

Dec(U): Unsigned decimal number 

HEX: Hexadecimal number 

Delete All Collectively deletes all the registered variables. 

Delete Selected Rows Deletes the selected variable. 

Multiple rows can be deleted at once by using the Shift key. 

Copy Selected Rows Copies the selected variable. 

Multiple rows can be copied at once by using the Shift key. 

Paste Selected Rows Pastes the variable copied by "Copy Selected Rows." 
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4.3.6 Notes 

● Even when READ/WRITE is executed while multiple items are selected, the data in the 

processor will not be read or written simultaneously. Pay attention when changing the 

value of variables which require accurate synchronization. 

● The Inspector window can be resized. 

When the registered variables are hidden by resizing, a scroll bar will be displayed. 

When Read Enable / Write Enable set to enable, the hidden variables will also become 

the target of the reading/writing. 

● When an address not disclosed to a user is specified, the value of the Read Value will be 

masked, and "********" will be displayed. 

● When the Inspector window is turned off, the currently set contents will be saved 

automatically. 

The saved contents will be reproduced when the system is started the next time. 

● If Inspector is opened during any recompilation of program or change in variable names, 

the variables in Inspector will not be updated during Download. After compilation, 

“Variable Information in Inspector Updated” will be displayed. 

● Write Enable is unavailable for all pointer variables. Read Value will be displayed. 

● At assembler level, variables other than double type are read / written with one 

instruction, so the values are synchronized (atomic). However, since variables of type 

double are read / written by 2 instructions, values may be rewritten from the user 

program between the lower 4 bytes and the higher 4 bytes read / write. Therefore, as for 

the value of double type variable, it is a reference value because value synchronization 

(atomic) can not be guaranteed. This applies not only to Inspector, but also to all 

windows that Read Value / Write Value of variables in WAVE / Data Rec. 
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4.4 WAVE Window 

The WAVE window displays the waveforms of specified variables in real time. 

It also performs an FFT analysis of the read waveform data and displays the data. 

In WAVE, variables for up to 16 CH can be registered to display the waveforms. 

 

4.4.1 Starting 

There are two methods to display this window. 

- Click the Window menu → Show Window →WAVE 

- Click WAVE on the tool buttons. 

 

When started, the following screen will be displayed. 

 

 

Figure 83: WAVE Window  
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4.4.2 Screen Structure 

The screen structure of WAVE is as shown below: 

 

Figure 84: Control Panel Window 

 

Outline view 

graph

Enlarged 

view graph

  

Figure 85: Graph Window 
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Figure 86: FFT Window 

 

The contents of each window are as follows: 

 

Table 40: Contents of WAVE Window 

Windows Contents 

Control panel window This window is for specifying the display conditions and trigger 

conditions. 

When this window is closed, the graph window and FFT window 

will also be closed automatically. 

Graph window Displays the outline view graph and enlarged view graph. 

The outline view graph displays all the data. 

The enlarged view graph enlarges and displays the selected data 

range. 

FFT window Displays the results of the fast fourier transform (FFT) performed 

for the read waveform data. 
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4.4.3 Outline of WAVE Function 

The WAVE function is provided with several settings that are required to display a waveform. 

This section describes the outline of these functions. See description of each function for 

details. 

 

Trigger conditions setting

Display format setting

Variable selection

Y-axis range setting

Position setting

ACQ LED

Changing of CH/MATH/X-Y/

FFT tabs

X-axis range setting of 

enlarged graph display

Display position setting of 

enlarged graph display
Magnification setting of 

enlarged graph display

   Run/ Stop

Cursor ON/OFF

 

Figure 87: Explanatory View of Each Function (CH 1 to 16 Screen) 

 

※ Except that the display of the applicable channels of CH 5 to 16 changes to 5 to 16, the 

other functions are the same as the above screen. 
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Display format setting

Equation setting

Y-axis range setting

Position setting

 

Figure 88: Explanatory View of Each Function (MATH Screen) 

 

Position setting

Display format setting

X-axis and Y-axis range 

setting

X-axis and Y-axis source 

channel selection

 

Figure 89: Explanatory View of Each Function (X-Y Screen) 
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FFT screen display

Frequency displayHold display

Root mean square 

value display
Mean value display

 

Figure 90: Explanatory View of Each Function (FFT & DMM Screen) 
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Common Trigger 
conditions

Settings of each 
individual trigger 

condition

 

Figure 91: Explanatory View of Each Function (Trigger Screen) 
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4.4.4 Control Panel Window Functions 

This section describes each of the functions on the WAVE control panel window. 

In the control panel window, the acquisition of waveform data, various display changes, 

setting of each function, etc. can be performed. 

 

1) Acquiring waveform data 

Click the RUN/STOP button to acquire the waveform data. Continuous acquisition and 

single acquisition are performed in the trigger mode. 

While running, the status changes to the trigger standby state according to the trigger setting, 

and when the trigger starts the waveform will be updated. ACQ turns ON while data is being 

transferred. 

 

 

Figure 92: Display While Stopped 

 

The displays changes to the following while running. 

 

 

Figure 93: Display While Running 

 

Click the RUN/STOP button again to end the acquisition of the waveform data. 
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2) Setting enlarged display 

 

Figure 94: RANGE and POSITION 

 

Since the graph window allows the recording of data for a long period, this window consists 

of an outline view graph that displays the overall outline, and an enlarged view graph that 

expands a portion of the waveform. 

The following describes the settings of the enlarged view of a waveform. 

To set the enlarged view, adjust the value of RANGE on the control panel window to set the 

scaling factor to be displayed. The RANGE can be set from 0.1% to 100% of the maximum 

range. 

However, the range which can actually be set changes by the value of HORIZONTAL 

SEC/DIV. 

Next, adjust the value of POSITION to set the offset time from the trigger point. 

Click the right or left button of the list box, or directly enter a value in the text box to set the 

position. 

 

Position and range enclosed in white 

frame is displayed in an enlarged scale
Graduation width of X-axis of 

outline view graph

Graduation width of X-axis of 

enlarged view graph  

Figure 95: Enlarged Display of Waveform 
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3) Cursor ON/OFF 

To display the cursor on the enlarged view graph, click the CURSOR button on the control 

panel window. 

 

 When cursor display is OFF 

 When cursor display is ON 

Figure 96: CURSOR Button Status 

 

When the cursor display is ON, the values of Cursor A, Cursor B, |A-B| and 1/|A-B| will be 

displayed on the status bar of the graph window. In each CH and the MATH area, the cursor 

values of "-A-" and "-B-" will be displayed on the lower part of the enlarged view graph. 

To move Cursor A and Cursor B, move the mouse over the cursor character ("A" and "B") of 

the enlarged view window, and drag to a position. 

Displays the values on the status bar when ONDisplays the values of Cursors A and B

Cursor display ON: Displays the portion indicated by the arrows

     

Figure 97: Status When Cursor Display Is ON 
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For each cursor, different modes will be displayed. 

Table 41: Differences in values of cursors 

Mode Display 

Interpolation enabled: 

([Option] → [Smooth]: ON) 

Interpolation data is displayed. 

Interpolation disabled: 

([Option] → [Smooth]: OFF) 

Each data point is displayed. Between 2 points, the data on 

the left will be displayed when the cursor is present. 
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4) Changing range of waveform display 

To change the range of a waveform display, change the following portions. 

 

(X-axis) 

●Change X-axis of CH1 to 16 and MATH1 to 8: 

HORIZONTAL SEC/DIV 

●Change X-axis of XY-1 and XY-2: 

[X-VAL/DIV] of each X-Y function 

 

(Y-axis) 

●Change Y-axis of CH1 to 16 and MATH1 to 8: 

Each [VAL/DIV] of CH and MATH 

●Change Y-axis of XY-1 and XY-2: 

[Y-VAL/DIV] of each X-Y function 

 

Change Y-

axis range

Change X-axis range

 

Figure 98: Changing of Ranges (CH1 to 16 Screen) 
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Change X-axis range

Change Y-

axis range

 

Figure 99: Changing of Ranges (MATH Screen) 

 

Change Y-axis range

Change X-axis range

 

Figure 100: Changing of Ranges (X-Y Screen) 
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Click the up/down button of the list box, or directly enter a value in the text box to set the 

range. 

When entering a value directly, be careful the range width and unit below: 

(X-axis) 100us to 200 second/DIV 

(Y-axis) 100u to 50 M/DIV 

(Units) u: micron 10-6), m: millimeter (10-3), k: kilo (103), M: mega (106) 

  

● Changing range width and units 

If the value is less than 1, use units of (u, m), and only use (k, M) when larger than 1. 
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5) TRIGGER Settings 

Up to 4 triggers can be displayed. For multiple trigger conditions, if any condition is 

fulfilled,trigger is enabled. (OR condition). Refer to the image below for trigger setting. 

 

[COMMON] 

Set the common trigger condition for Trigger 1～4. 

 

Figure 101: Common trigger conditions 

 

[EACH] 

Individual setting for each trigger 1～4 is displayed as below. 

 

③ Select Trigger ④ Enable or disable 
trigger

⑤ Trigger CH setting

⑥ Set trigger position (y-axis)

⑦ Individual trigger setting
 

Figure 102: Individual Trigger Setting 

 

② Trigger Setting (AUTO/NORMAL/SINGLE) 

① Set trigger position (x-axis) 
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●Trigger Setting (AUTO/NORMAL/SINGLE) [ ① ] 

This item is common for all triggers. 

 

・AUTO 

The trigger signal is generated within a certain time (timeout time, approximately one screen 

of the display). The waveform is displayed in synchronization with the trigger signal and the 

waveform is automatically captured after the timeout time. In AUTO mode, the waveform 

has a cycle longer than the timeout time 

 

・NORMAL 

The waveform is captured and displayed only when the trigger condition is met during RUN. 

If the trigger condition is not met, the trigger enters a “wait” state. 

 

・SINGLE 

If the trigger condition is met during RUN, the waveform is retrieved once and it stops. If the 

trigger condition is not met, the trigger enters a “wait” state. 

 

Note that it is possible to change the trigger mode during waveform display (during RUN). 
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● Set trigger position (x-axis) [ ② ]/ Set trigger position (ｙ-axis)[ ⑥ ]    

The trigger position for x-axis is common in trigger 1～4. 

The trigger position for y-axis is different in trigger 1～4. 

 

When CH1 to 16 is selected as the trigger channel, the trigger point will be set at the point of 
the intersection of the set trigger level and trigger position (see figure below). 

 

Trigger position

Trigger level (Trigger No.1)

Trigger level (Trigger No.2)

Trigger level (Trigger No.3)

Trigger level (Trigger No.4)

 

Figure 103: Explanatory View of Trigger Function 

 

There are 4 methods to set triggers. 

 

(i) Drag the trigger level and trigger position (▼ mark) in the outline view graph. 

(ii) Drag the trigger level (▼ mark) in the enlarged view graph. 

(iii) Click the up/down button (trigger level) and the right/left button (trigger position) of 

the list box on the control panel window to change the value. 

 

  

Figure 104: Setting Trigger Level and Trigger Position 

 

To set the interval which changes the value, move one graduation at a time in the 

graduation unit of VL/DIV and HORIZONTAL SEC/DIV in each outline view graph. 

Ex.: Trigger level VAL/DIV is set to 1.00 

→ ..., -1.00, 0.00, 1.00, ...) 

Ex.: Trigger position HORIZONTAL SEC/DIV is set to 1.00m 

→ ..., -1.00m, 0.00, 1.00m, ...) 

※ Generally, the value will changed for each range width set in VAL/DIV and 
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HORIZONTAL SEC/DIV. 

※ The value set in HORIZONTAL SEC/DIV displayed on the control panel window is the 

setting value in the enlarged view graph. The HORIZONTAL SEC/DIV in the outline view 

graph is determined by the setting value on the control panel window and the display scaling 

factor (RANGE). 

 

(iv) Directly enter the value in the list box of the control panel window. 

    

Figure 105: Setting Trigger Level and Trigger Position 

 

Note that the trigger position is based on the outline view graph. 

Ex.: Trigger level VAL/DIV is set to 1.00 

→ Setting range: -4.00 to 4.00 

Ex.: Trigger position HORIZONTAL SEC/DIV is set to 1.00m 

→ Setting range: -5.00m to 5.00 

※ Generally, the range of the trigger level is (-4xVAL/DIV) to (4xVAL/DIV), and the range of 

the trigger position is (-5xHORIZONTAL SEC/DIV) to (5xHORIZONTAL SEC/DIV). 
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●Select Trigger [ ③ ] 

The trigger level position for y-axis is different for each trigger 1～4. 

 

Select the trigger from the list first. 

 

 

Figure 106: Select Trigger 

 

●Enable / Disable Trigger [ ④ ] 

Each trigger is enabled / disabled individually. 

Check each box to enable trigger. For the example below, only Trigger 1 is enabled. 

 

 

Figure 107: Enable / Disable 

 

● Trigger CH Setting [ ⑤ ] 

Each trigger CH is enabled / disabled individually. 

The setting includes CH1-16 and EXT. EXT refers to external trigger. When EXT is selected, 

rising or falling from external signal is triggered. The range is from 0-5V. 

 

 

Figure 108: Trigger CH Setting 
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●Individual Trigger Setting [ ⑦ ] 

The setting for each trigger CH is different.. 

 

 

Figure 109: Individual Trigger Setting 
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For each trigger, the following items are displayed. 

   

Item Contents 

EDGE In EDGE selection, trigger is set in rising/falling edge 

 rising edge 

  falling edge 

※ When EXT is selected, rising or falling from external signal is triggered. The 

range is from 0-5V. 

WIDTH When WIDTH is selected, trigger is enabled at pulse width. Pulse width refer to 

“smallest width between trigger level and cross point” in WAVE 

 Set pulse width 

  Min： Sampling frequency x 2 

  Max： SEC/DIV x 9 

(SEC/DIV is the conversion of RANGE=100) 

Type：trigger enabled when value is larger or smaller than pulse width 

  trigger when larger than pulse width 

  trigger when smaller than pulse width 

Polarity： trigger enabled in positive polarity / negative polarity 

  trigger in positive polarity 

  trigger in negative polarity 
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● Display of Trigger Information 

For each trigger 1～4, the following window will be displayed. 

 

Trigger HitTrigger Mode

Each Trigger

Each Trigger Level

Trigger Position

 

Figure 110: Display of Trigger Information 

 

Table 42: Display of Trigger Information 

Items Contents 

Trigger Position Trigger position setting in [POSITION] 

Trigger Mode Display of AUTO/ NORMAL/ SINGLE 

Trigger Hit No. Display of Trigger Hit No. (“TRG1 ～ TRG4”) 

In AUTO mode, waveforms will be refreshed continuously in 

defined time. In this caes, ”No Trg” is displayed. 

Each Trigger Each trigger is displayed. 

↑： rising edge 

↓： falling edge 

< ： trigger pulse is larger than setting 

> ： trigger pulse is smaller than setting 

Each Trigger Level Trigger level setting in [LEVEL] 
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6) Setting CH1 to 16, MATH and X-Y waveform display to ON/OFF 

To change the setting of the waveform display of CH1 to 16, MATH and X-Y to ON/OFF, click 

the ON/OFF button provided for each CH on the control panel window as shown below. 

ON/OFF 

button

 

Figure 111: ON/OFF Button (CH1 to CH16 Screen) 

ON/OFF 

button

 

Figure 112: ON/OFF Button (MATH Screen) 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 119/217 2017/09/19 

 

ON/OFF button

 

Figure 113: ON/OFF Button (X-Y Screen) 
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7) Extension Window 

Up to 4 extension windows can be selected for CH1-16, MATH and X-Y graph. In the image 

below, click on [Win1] to change the display of waveform. [Win1]～[Win4] can be switched. 

[Win1]～[Win4]  is displayed in Image 1～Image 4 

 

[Win1]

 

Figure 114: [Win1] (CH1-16 Display) 
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[Win1]

 

Figure 115: [Win1] (MATH Display) 

 

[Win1]

 

Figure 116: [Win1] (X-Y Display) 
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Extension windows are shown as below. 

 

● For 1 image 

(Eg)CH1/ CH2/ CH3/ CH4 -- Win1 

Other CH are not displayed 

 

Figure 117: Magnified Graph (Image 1) 

 

● For 2 images 

(Eg)CH1/ CH2 -- Win1 

CH3/ CH4 -- Win2 

Other CH are not displayed 

 

 

Figure 118: Magnified Graph (Image 2) 
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● For 3 images 

(Eg)CH1/ CH2 -- Win1 

CH3 -- Win2 

CH4 -- Win3 

Other CH are not displayed 

 

 

Figure 119: Magnified Graph (Image 3) 

 

● For 4 images 

(Eg)CH1 -- Win1 

CH2 -- Win2 

CH3 -- Win3 

CH4 -- Win4 

Other CH are not displayed 

 

 

Figure 120: Magnified Graph (Image 4) 
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8) Setting offset 

Clicking the OFFSET button of each CH (CH1 to 16) displays the following screen and 

allows the Offset value to be set. To set the value, enter the Offset value directly. 

 

Figure 121: Offset Value Setting (CH1) 

 

The Offset function is for displaying the value in which a fixed value (Offset value) is added 

to the target variable by the waveform display software. All the values used for numerical 

processing and display by the waveform display software are the values after the Offset is 

added. Note that each channel data transferred to the MATH function and the X-Y function is 

also data after the Offset is added. 

 

The example shows that Offset value "1" is added to CH1. 

 

Waveform display and value changes for the amount of Offset added

 

Figure 122: Offset Value Display (CH1) 
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When the X-Y function is displayed in this state, the following X-Y waveforms will be 

displayed. 

 

Displayed in the state where the Offset value of CH1 is included

 

Figure 123: Offset Value Display (X-Y) 
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9) Selecting variable 

To select the variable to be displayed, click the pull-down menu (▼ button) of VARIABLE 

on the control panel window. 

 

 

Figure 124: Variable Selection 

 

The variable can be selected from the following two methods. 

- Select a variable name with the mouse. 

- When the first character of a variable name is entered, the applicable variable name will be 

selected automatically. 

 

The variables listed in VARIABLE are displayed based on the variable information file 

automatically created by PE-ViewX. 
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10) Selecting display colors of waveform 

To set the waveform color of each CH, MATH and X-Y, or the spectral color of the FFT, click 

the color list. The following color selection dialog will be displayed. 

   

 

Figure 125: Waveform and FFT Spectral Color Setting 
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11) Setting POSITION 

To set the POSITION of CH1 to 16 and MATH, set the value in POSITION as follows: 

 

 

Figure 126: POSITION Setting (CH1 to 16, MATH) 

 

The position can be set by the following three methods. 

- Place the cursor on the dial, and rotate the mouse wheel. 

- Click the Up/Down buttons of the list box. 

- Directly enter a value. 

 

※ The setting range is from "(-4xVAL/DIV) to (4xVAL/DIV)." 

 

Click the POSITION button for the X-Y function. 

The following dialog will be displayed. 

 

 

Figure 127: POSITION Setting (X-Y) 
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The following shows the waveform when POSITION is set. Use these figures as a 

reference. 

 

Changes the reference value (Arrow)

 

Waveform display and value changes for amount of offset added

 

Figure 128: POSITION Display (CH1) 

 

12) How to change CH1 to 16, MATH and X-Y screens 

On the control panel window, the CH1 to 16, MATH and X-Y screens can be selected. To 

change the screen, directly click the tab to select, or press the [Tab] key on the keyboard. 
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13) Setting EQUATION 

In the MATH function, there is an EQUATION function which performs calculations using the 

value and constant of each CH. 

The calculation results can be displayed in the waveform. See the following figure for an 

example of the contents and setting of the EQUATION function. 

 

 

Figure 129: Example of EQUATION (Case of multiplication of CH1 and CH2) 

  

Table 43: Specification of Valuation Equation 

Function Names Notations Description 

Input source $1 to $16 Provides input source used for calculation. 
The number is equivalent to the channel number. 

Time source $t Provides time used for calculation by second bit. 
The reference is the trigger setting position. 

Circular constant $p Provides circular constant. 

Constant 3.14 Provides constant used for calculation. 
Exponential notations cannot be used. 
The following notations can be used as a suffix. 
M: 106, K: 103, m: 10-3, u: 10-6 

Code inversion - Can be added to the beginning of an equation. 
The combinatory rule is based on common mathematic 
equations. 

Four arithmetic 

operations 

+-*/ Performs four arithmetic operations. 
The combinatory rule is based on common mathematic 
equations. 

Power ^ Calculates the power. 
The combinatory rule is based on common mathematic 
equations. 

Parenthesis () Forces the priority of the four arithmetic operations. 

Absolute value abs(x) Provides absolute value of given equation x. 

Sine function sin(x) Provides sine value of given equation x. 

x is the radian. 

sinh(x) Provides hyperbola sine value of given equation x. 

x is the radian. 

Cosine function cos(x) Provides cosine value of given equation x. 

x is the radian. 

cosh(x) Provides hyperbola cosine value of given equation x. 

x is the radian. 

Tangent function tan(x) Provides tangent value of given equation x. 

x is the radian. 

tanh(x) Provides hyperbola tangent value of given equation x. 
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Function Names Notations Description 

x is the radian. 

Inverse tangent 

function 

atan(x) Provides inverse tangent value of given equation x. 

x is the radian. 

Square root sqrt(x) Provides square root of given equation x. 

Between cursor 

A-B 

$ab Provides number of seconds [sec] between cursors A-B. 

Root mean 

square value ※ 

$rms1～ 

$rms16 
Provides root mean square value of input source n. 

Frequency ※ $Hz1～ 

$Hz16 
Provides frequency of input source n. 

Mean value ※ $mean1～ 

$mean16 
Provides mean value of input source n. 

 

※ These values conform to the processing results of the multimeter function. 
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14) Selecting source channel of X-Y screen 

The X-Y screen is a function for setting each CH to the X-axis and Y-axis to observe a 

waverform. Set the CH or the MATH channel to be displayed on the X-axis and Y-axis as 

shown below in SOURCE on the control window. 

 

 

Figure 130: X-Y Function Source Channel Setting 

 

15) On-Chip WAVE Settings 

   Set On-Chip WAVE. 

   On-Chip WAVE is a function which executes WAVE sampling and saves wave data 

   by PEOS in user program. 

   It is not necessary to run WAVE window of PE-ViewX. 

   This function can be used for failure analysis etc. 

   Saved wave data can be loaded to WAVE window of PE-ViewX and displayed. 

 

Figure 131: Setttings of On-Chip WAVE 

 

  Settings items are as follows. 

Table 44: List of items of On-Chip WAVE settings 

Items Contents 

Save Settings Saves current trigger conditions of WAVE to PE-Expert4. 

Trigger conditions are saved to Flash ROM, so it is retained 

even when turning off PE-Expert4. 

Saved wave data based on old trigger conditions are cleared 

when setting new trigger condtions. 

On-Chip WAVE starts sampling after clicking this button and 

execute user program. 
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Wave data is saved automatically to RAM when meeting the 

trigger conditions. 

Wave data in RAM is cleared when turning off PE-Expert4. 

To save wave data even after turning off PE-Expert4, 

call PEOS function which saves wave data to Flash ROM. 

Flash ROM can save wave data up to 1M byte. 

Wave data exceeding 1M byte is thinned out in Flash ROM. 

Retrive Data Loads saved trigger conditions and wave data to PE-ViewX. 

If wave data is saved in RAM, PE-ViewX loads it. 

If wave data is not saved in RAM, PE-ViewX loads it from Flash 

ROM. 

If wave data is not saved in RAM and Flash ROM, PE-ViewX 

loads only trigger conditions. 

 

●To use this function, it is necessary to call PEOS functions in version 3.04 or more. 

 To save wave data to Flash ROM, call the function which saves 

 WAVE data to Flash rom. 

 For more details, refer to [5.1.8 MWPE4-C6657 Board On-Chip WAVE Function Group] 

 in function reference manual. 

 The kernel version of DSP board needs to be upgraded to version 3.03 or more. 

 

●WAVE window of PE-ViewX has priority over On-Chip WAVE. 

 On-Chip WAVE cannot be executed while running WAVE window of PE-ViewX. 

 If the WAVE window of PE-ViewX is ran while executing On-Chip WAVE, 

 On-Chip WAVE stops. 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 134/217 2017/09/19 

 

4.4.5 Graph Window Structure 

This section describes the structure of the graph window. 

The structure is as follows: 

 

Menu

Outline view 

graph

メニュー

Enlarged view 

graph

Disp1/ Disp2

Status bar

 

Figure 132: Graph Window Structure 

 

1) Menu 

The menu consists of File / Option. 

See "4.4.5 Processing Waveform Data (File Menu)" and "4.4.6 Waveform Display Related 

Settings (Option Menu)" for the details. 
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2) Outline view graph 

The outline view graph displays all the acquired waveform data. 

The details are as follows: 

 

X-axis range Enlarged view graph area

POSITION Trigger position

Trigger level
Trigger mode

Trigger hit No.

Different triggers
 

Figure 133: Outline View Graph Structure 

 

Table 45: Outline View Graph Structure 

Names Functions 

X-axis range Indicates the range of the X-axis (SEC/DIV) of the outline 
view graph. 

POSITION Indicates the POSITION value set on each CH tab. 

Enlarged view graph area The area enclosed in the white frame in the outline view 
graph. 
This area is enlarged and displayed on the enlarged view 
graph. 
The range of the white frame is specified by the RANGE 
and POSITION. 

Trigger position Indicates where the trigger position is in the acquired 
waveform. 
Specified by POSITION in the TRIGGER field. 
The trigger position can also be specified by dragging the 
arrow right and left. 

Trigger level Indicates where the trigger level is in the acquired 
waveform. 
Specified by LEVEL in the TRIGGER field. 
The trigger level can also be specified by dragging the 
arrow up and down. 

Trigger mode Displays AUTO/NORMAL/SINGLE 

Trigger hit No. TRG1~TRG4 will be displayed as hit number. In case of 
AUTO mode, waveform will be displayed in fixed time 
despite of hit number. 

Different triggers The different formats of triggers are listed as below. 

↑：rising edge 

↓：falling edge 

<：pulse trigger, larger than setting 

>：pulse trigger, smaller than setting 

[LEVEL] displays the setting for all triggers 1~4. 
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3) Enlarged view graph 

The enlarged view graph enlarges and displays the area specified in the outline view graph. 

Up to 4 windows can be displayed. 

The details are as follows: 

 

x-axis range
Variable information of each CH

Disp1/ Disp2[POSITION] Trigger level

 

Figure 134: Enlarged View Graph Structure 

 

Table 46: Enlarged View Graph Structure 

Names Functions 

X-axis range Indicates the range of the X-axis (SEC/DIV) of the outline 
view graph. 

POSITION Indicates the POSITION value set on each CH tab. 

Disp1/Disp2 Displays the values set in the [Disp1/Disp2] fields. 
See "4) Disp1/Disp2" on the next page the details. 

Variable information of each 
CH 

Displays the measurement condition of each CH and the 
values in cursors A/B. 
The items which can be set change by the tabs of CH1 to 
16, MATH and X-Y. 

Trigger level Displays the trigger level in waveform. 
The settings are in [TRIGGER, ][LEVEL] 
The trigger level can be adjusted by drag and drop of the 
arrow. 
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4) Disp1/Disp2 

The contents set in these fields are displayed in the enlarged view graph as described on 

the previous page. 

The details are as follows: 

 

 

Change of display / hide

Display channels Display items Font size Average

 

Figure 135: Disp1/Disp2 Structure 

 

Table 47: Disp1/Disp2 Structure 

Names Functions 

Change of display / hide Changes between display/hide. 

Display channels For setting the channels to be displayed. 

Can be selected from CH1 to 16 and MATH1 to 8. 

Display items Can be selected from the following items: 

Value A: 

  Displays the value of cursor A. 

Value B: 

Displays the value of cursor B. 

Multimeter: 

  Displays the digital multimeter. 

See "4.4.8 DMM Display" for the digital multimeter. 

Font size For setting the font size. 

Average Used when Multimeter is selected. 

Calculates the average and frequency based on the mean 

value of the trigger data for the count specified here. 
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5) Status bar 

The status bar displays the following items. 

 

Sampling cycle Record length

Time between A-B Frequency between A-B Position of A-B  

Figure 136: Status Bar Structure 

 

Table 48: Status Bar Structure 

Names Functions 

Sampling cycle Displays the sampling cycle of the currently acquired 

waveform data. 

The sampling cycle is set based on the record length and 

the HORIZONTAL SEC/DIV value. 

 

Sampling frequency = ([HORIZONTAL SEC/DIV] x 10 ) / 
[Record Length] 

 

However, if the calculated sampling frequency falls below 

the minimum value of sampling frequency, the value 

remains at minimum value. 

 

The minimum sampling frequency is displayed as below: 

 

When [Channel Mode] is [16CH]: 10μsec 

When [Channel Mode] is [8CH]: 5μsec 

Record length Displays the record length (point) of the currently acquired 

waveform data. 

Indicates the record length per 1CH. 

Time between A-B Displays the time difference between cursor A and cursor B. 

Frequency between A-B Displays the inverse, i.e. the frequency of the time 

difference between cursor A and cursor B. 

Position of A and B Displays the position on the time of cursor A and cursor B. 

The center of the enlarged view graph is 0. 
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4.4.6 Processing Waveform Data ([File] Menu) 
This section describes the functions of the File menu of the graph window. 

The main functions include the Save/Load functions of waveform data, Save/Load functions 

of the control panel window, etc. The following describes each of the functions. 

Since the File menu cannot be used while running, stop the operation before use. 

 

1) Saving waveform display data ([Save WAVE Data]) 
The waveform display data (waveform data and setting information of the control panel 

window) can be saved in a file. 

Select the File menu → Save WAVE Data File. 

When this function is executed, the following entry dialog of Save Comment will be 

displayed. Enter the required information, and click the OK button. 

An Ext. file ".wd6" will be created for the waveform display data. 

 

 

Figure 137: Save Comment Entry Dialog 

 

 
Figure 138: Waveform Data Saving Completed Dialog 

 

※ Relationship between the offset function and data saving 

The Offset function is for displaying the value in which a fixed value (Offset value) is added 

to the target variable by WAVE. All the values used for numerical processing and display by 

WAVE are the values after the Offset is added. 

However, the Offset value is not included in the saved waveform data. When the saved 

waveform data is read to WAVE, the data including the Offset value set when the waveform 

data is read will be displayed. Pay particular attention to this point. 
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2) Saving waveform display csv data ([Save WAVE Data as CSV]) 
The waveform display data (csv data and setting information of the control panel window) 

can be saved in a file. 

Select the File menu → Save WAVE Data as CSV. 

When this function is executed, the following entry dialog of Save Comment will be 

displayed. Enter the required information, and click the OK button. 

This file cannot be opened in WAVE. 

 

3) Loading waveform display data ([Load WAVE Data]) 
The waveform display data file saved by the Save WAVE Data File function can be loaded. 

Select the File menu → Load WAVE Data File. 

When the file to be loaded is specified, the following dialog will be displayed. 

Click the OK button to complete the loading. 

 

 

Figure 139: Waveform Data Loading Completed Dialog 

 

4) Saving setting information (Save Configuration File) 
Information including the variables, range, POSITION settings, etc. set in the control panel 

window can be saved in a file. 

Select the File menu → Save Configuration. 

When this function is executed, the following save comment entry dialog will be displayed. 

Enter the required information, and click the OK button. 

 

 

Figure 140: Configuration File Saving Completed Dialog 

 

 

An Ext. file ".cf6" will be created for the variables, range, POSITION settings, etc. set in the 

control panel window. 
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※Setting information file (Ext. *.cf6). 

The file (Ext.: .cf6) where the setting information is to be saved will be created automatically 

when the control window is closed, and the contents set in the control window at that time 

will be saved. The file name created automatically is "project name.cf6." 

(Ex.: "tutor" project → "tutor.cf6" will be created) 

 

5) Loading setting information ([Load Configuration]) 
The setting information file of the control panel window saved by Save Configuration File 

can be loaded. 

Select the File menu → Load Configuration. 

When the file to be loaded is specified, the following dialog will be displayed. 

Click the OK button to complete the loading. 

 

 

Figure 141: Configuration File Loading Completed Dialog 

 

6) Copying to clipboard ([Copy to Clipboard]) 

The waveform data currently displayed can be copied to a clipboard. 

Select the File menu → Copy to Clipboard. 

When pasting, use the paint tool, etc. 
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7) Saving comments ([WAVE Data Comment]) 
Comments can be saved to the waveform display data file (Ext. *.wd6) loaded by the Load 

WAVE Data File function. 

Select the File menu → WAVE Data Comment. 

This function is only enabled after the waveform display data file is loaded by Load WAVE 

Data File, and it cannot be used for any other purpose. 

When this function is executed, the following dialog will be displayed. To update the 

comment information, click the Update button. 

Click the Clear button to clear all comments. 

 

 

Figure 142: WAVE Comment Dialog 

 

8) Printing ([Print]) 
The contents displayed in the graph window can be printed. Select the File menu → Print. 

 

9) Print preview ([Print Preview]) 

The contents to be printed can be previewed. Select the File menu → Print Preview. 
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4.4.7 Waveform Display Related Settings ([Option] Menu) 
This section describes the functions of the Option menu of the graph window. 

The settings related to the waveform display are performed in this menu. 

 

1) Setting display color ([Set System Color]) 
To set the background color and cursor color of the graph window, click the Option menu → 

Set System Color to display the following dialog. 

 

 

Figure 143: Background Color and Cursor Color Setting 

 

Back Color : Background color of graph window 

System Color : Grid line color of graph window 

Cursor A : Display color of Cursor A 

Cursor B : Display color of Cursor B 

Cursor Grab : Display color when setting Cursor and Trigger 

Cursor Grab refers to the color displayed when Cursor A, 

Cursor B, trigger position and the trigger level are being 

moved in the graph window while dragging by the mouse. 

 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 144/217 2017/09/19 

 

2) Setting font size ([Font Size]) 
The font size of the characters displayed in the data portion of the graph window can be set. 

Select the Option menu → Font Size. 

The size can be set from Small, Medium or Large. 

 

Font size

(Small)

 
 

Font size

（Large)

 

Figure 144: Font Size Setting 
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3) Setting waveform pixel size ([Pixel Size]) 
The waveform pixel size of the graph window can be set. 

Select the Option menu → Pixel Size. 

The size can be set from Small, Medium or Large. 

 

Pixel size 

(Small)

 
 

Pixel size 

(Large)

 

Figure 145: Pixel Size Setting 
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4) Changing interpolation display of waveform ([Smooth]) 
Whether to interpolate the data for the sampling point of the waveform of the graph window 

to be displayed can be set. 

Select the Option menu → Smooth. 

When this function is set to ON, the interpolated waveform data will be displayed as follows: 

 

 
 

 

Figure 146: Smooth Setting OFF (Upper Graph) / Smooth Setting ON (Lower 

Graph) 

 
※ In consideration of the effect on the drawing speed, even when the Smooth function is 

turned OFF, if the number of dots on the outline view graph/enlarged view graph reaches 
300 points or more, the interpolated data will be displayed in each graph. 
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5) Setting graduation lines of waveform ([Grid Type]) 
The type of graduation line (grid line) of the graph window can be set. 

Select the Option menu → Grid Type. 

The type can be set between Dot or Line. 

 

Graduation 

line

（Dot)

 
 

Graduation 

line

（Line)

 

Figure 147: Graduation Line Setting 
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6) Setting display items ([Display Item]) 

The items displayed on the lower part of the enlarged view graph can be set. 

Select the Option menu → Display Item. 

 

 

Figure 148: Display Item Setting 

 

Display 

items

 

Figure 149: Display Items which can be set 
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7) Setting record length of waveform data (Record Length) 

The maximum record length (point) acquired from the waveform data can be set. 

Select the Option menu → Record Length. 

The record length can be selected from a range of 50 to 524288. 

The value set here becomes the maximum record length per 1CH. 

However, since the record length actually acquired will be calculated based on the value 

specified here and the current measurement conditions, the value may become smaller than 

the value specified here. 

The record length actually acquired will be displayed on the status bar of the graph 

window. 

 

Figure 150: Record Length Setting 
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8) Setting channel mode ([Channel Mode]) 

The number of channels of waveform data to be acquired can be set. 

Select the Option menu → Channel Mode. 

The number of channels can be selected between 16CH or 8CH. 

 

[16CH] mode: 

The waveform data for 16CH is acquired from the PE-Expert4. 

The minimum sampling cycle is 10us. 

[8CH] mode: 

The waveform data for 8CH is acquired from the PE-Expert4. 

The minimum sampling cycle is 5us. 

The value of the 9 to 16CH is fixed at 0. 
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4.4.8 FFT Analysis Display 

1) FFT analysis function 

The FFT analysis function is for performing a frequency analysis of the read waveform data. 

Fast Fourier Transform (FFT) is used as the method of the frequency analysis. The power 

spectral graph and the value of the total harmonic distortion (THD) can be displayed as 

analysis results. 

 

 

Figure 151: Spectral Display 
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Figure 152: THD Display 

 

The range of frequency analysis supports two modes: the full screen mode for one screen of 
waveform data; the cursor mode for between cursors A-B used on the waveform display 
(WAVE) screen. 
Since the FFT requires the n-th power of 2 (n is a positive integer) as the number of samples, 
the data is interpolated by linear interpolation before the FFT is performed. An interpolation 
image is shown below. 

Converted from 5 

samples to 8 

samples

 

Figure 153: Data Process Before Analysis 
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※ Window functions 

Note that the window functions are not used in the FFT analysis function provided in WAVE. 

 

The components of each order of the FFT are calculated by the following equation: 
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Where, 

aj expresses the sample data. 

Pk expresses the components of the k-th order. 

N expresses the number of samples. 

 

In the power spectral display of the FFT, the DC component is displayed as the 0-th order 

item. 

The first-order component becomes the fundamental wave component. The fundamental 

wave frequency acts as the data range which performs the FFT process. 

 

In the THD display, the content of the THD and the odd order, content of the even order and 

the content of each order is displayed. 

THD is calculated by the following equation: 
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In the above equation, the content of the odd order is calculated for the odd number of a 

3rd-order or higher of Pk. 

In the above equation, the content of the even order is calculated for the even number of a 

2nd-order or higher of Pk. 

The content of each order is calculated by the following equation: 
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2) Tool bar 
The following describes the tool bar of the FFT window. 

 

Changes to cursor display mode

Changes to enlarged display mode

Resets the enlarged display

Changes to spectral display Changes to THD display
 

Figure 154: FFT Window Tool Bar 

 

The details of each function are as follows: 

 

Table 49: FFT Window Tool Bar 

Names Functions 

Changes to cursor 

display mode 

(Cursor) 

Changes the mouse operation during the spectral display mode to 

the cursor display mode. 

Left-clicking on the graph display area moves the cursor to the 

clicked position, and displays the frequency and its component 

(amplitude) on the lower left side of the screen. 

This function can be canceled by changing to the enlarged display 

mode. 

Changes to enlarged 

display mode 

(Enlarge) 

Changes the mouse operation during the spectral display mode to 

the enlarged display mode. 

Dragging the area to be enlarged in the graph display area will 

enlarge the selected area to be displayed. 

This function can be cancelled by changing to the cursor display 

mode. 

Resets the enlarged 

display 

(Reset Enlarged 

View) 

Resets the enlarged spectral display, and returns to the status 

where the entire graph is displayed. 

Changes to spectral 

display 

(Spectrum) 

Changes to the spectral display. 

Changes to THD 

display 

(THD) 

Changes to the THD display. 
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3) Menu 
The following describes the menus of the FFT window. 

 

 

Figure 155: FFT Function Menu 

 
The details of each menu are as follows: 

 

Table 50: FFT Function Menu 

Main Items Sub Items Contents 

File Print This is for printing the FFT graph. 

Print Preview This is for previewing the FFT graph. 

Option Display Channel This is for selecting the CH to be the target of the 

FFT. 

Select from CH1 to 16. 

Mode This is for changing the mouse operation. 

Select from the following. 

Cursor: 
This is the same function as [changes to cursor 
display mode] of the tool bar. 

Enlarge: 

This is the same function as [changes to 
enlarged display mode] of the tool bar. 

Reset Enlarged View This is the same function as [resets the enlarged 

display] of the tool bar. 

View This is for changing the display. 

Spectrum: 

This is the same function as [changes to spectral 

display] of the tool bar. 

THD: 

This is the same function as [changes to THD 
display] of the tool bar. 

Grid Type This is for changing the setting method of the 

graduation of the frequency axis and component 

axis. Select from the following: 

Liner: 

Linear display 

Log: 

Logarithmic display 
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Main Items Sub Items Contents 

 Analysis Range This is for changing the target range of the FFT 

analysis. 

Select from the following: 

Full Screen: 

All waveform data 

A-B Cursor: 

Waveform data between cursor A-B of the graph 

window 

 Number of THD This is for setting the maximum order of the THD 

which can be displayed while running. 

All the THD values will be displayed while stopped. 
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4.4.9 DMM Display 
The DMM display function provides the functions of the digital multimeter. 
This function displays the mean value, frequency and root mean square value in the 
enlarged display window. 
To use this function, select Multimeter in the pull-down menu of the graph window. 
In the FFT/DMM screen of the control window, select the DMM type (mean value, frequency, 
root mean square value). 

Set CH1 to Multimer to display the frequency Set CH2 to Multimer to display the root mean square value

 

Figure 156: DMM Settings and Display (Graph Window) 

 

Set CH1 to frequency Set CH2 to root mean square value

 

Figure 157: DMM Type Setting (Control Window) 
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There are four types of display modes: HOLD, RMS, Hz and Mean. 

The details of each function are as follows: 

 

Table 51: DMM Functions 

Items Functions 

HOLD Fixes the display data 

RMS Displays the root mean square value 

Hz Displays the frequency 

Mean Displays the mean value 

 

●HOLD 

This function fixes the display when the HOLD check box is selected. 

 

●RMS 

This function displays the root mean square value each time new data is acquired. 

<Calculation method> Displays the root mean square of all the data. 

N
RMS

N

k
kD

 1

2

    N = Total number of data, Dk = each data 

    

●Hz 

This function displays the frequency each time new data is acquired. 

<Calculation method> 

1. Calculates the mean value of all data. 

2. Subtracts the value of 1. from all data (removes the DC component). 

3. Searches all the zero crossing points of each data in a single direction. 

(The zero crossing point is determined by the code of the initial data.) 

4. Calculates the time interval of the zero crossing point acquired in 3. 

5. Sorts the time interval calculated in 4. by time. 

6. Determines the median value of the time interval data sorted in 5. as Hz. 

When the number of data is an even number, the value with the larger frequency is 

displayed. 

 

●Mean 

This function displays the mean value each time new data is acquired. 

<Calculation method> Displays the mean value of all data. 

N
Mean

N

k
kD

 1     N = Total number of data, Dk = each data 
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4.4.10 Short-cut Keys 

In WAVE, a short-cut key is assigned to each function, and can be operated from a 

keyboard. 

The short-cut keys and functions are as follows: 

 

Table 52: MAIN Functions 

Keys Functions 

R Toggles between Run/Stop 

C Toggles the cursor to display/hide 

[Tab]  Toggles between the Channels, Math, X-Y and FFT/DMM tabs 

[SHIFT] + [Tab] Toggles between the Channels, Math, X-Y and FFT/DMM tabs 
(Reverse order of the above) 

[Ctrl] + T Toggles between the control window, graph window and FFT 
window 

[Ctrl] + [SHIFT] + T Toggles between the control window, graph window and FFT 
window (Reverse order of the above) 

 

Table 53: ZOOM Functions 

Keys Functions 

Z + ← Enlarges the display area of the enlarged view graph (RANGE 
value becomes lower) 

Z + → Reduces the display area of the enlarged view graph (RANGE 
value becomes higher) 

P + ← Moves the display area of the enlarged view graph to the right 

P + → Moves the display area of the enlarged view graph to the left 

 

Table 54: SEC/DIV Functions 

Keys Functions 

←     :SEC/DIV を大きく Reduces the SEC/DIV 

→ Increases the SEC/DIV 
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Table 55: VAL/DIV Functions 

Keys Functions 

1 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH1 

2 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH2 

3 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH3 

4 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH4 

5 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH5 

6 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH6 

7 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH7 

8 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH8 

9 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH9 

A + 0 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH10 

A + 1 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH11 

A + 2 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH12 

A + 3 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH13 

A + 4 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH14 

A + 5 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH15 

A + 6 + { ↑ or ↓ } Increases/decreases the VAL/DIV of CH16 

[SHIFT] + 1 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH1 

[SHIFT] + 2 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH2 

[SHIFT] + 3 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH3 

[SHIFT] + 4 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH4 

[SHIFT] + 5 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH5 

[SHIFT] + 6 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH6 

[SHIFT] + 7 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH7 

[SHIFT] + 8 + { ↑ or ↓ } Increases/decreases the VAL/DIV of MATH8 

[Z] + 1 + { ↑ or ↓ } Increases/decreases the X-VAL/DIV of XY-1 

[Z] + 2 + { ↑ or ↓ } Increases/decreases the Y-VAL/DIV of XY-1 

[Z] + 3 + { ↑ or ↓ } Increases/decreases the X-VAL/DIV of XY-2 

[Z] + 4 + { ↑ or ↓ } Increases/decreases the Y-VAL/DIV of XY-2 
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Table 56: Trigger Functions 

Keys Functions 

M Toggles between Single, Auto and Normal 

[Shift] + M Toggles between Single, Auto and Normal (Reverse order of the above) 

N + 1 Selects Trigger No. 1 

N + 2 Selects Trigger No. 2 

N + 3 Selects Trigger No. 3 

N + 4 Selects Trigger No. 4 

T + 1 Selects 1CH as the trigger channel 

T + 2 Selects 2CH as the trigger channel 

T + 3 Selects 3CH as the trigger channel 

T + 4 Selects 4CH as the trigger channel 

T + 5 Selects 5CH as the trigger channel 

T + 6 Selects 6CH as the trigger channel 

T + 7 Selects 7CH as the trigger channel 

T + 8 Selects 8CH as the trigger channel 

T + 9 Selects 9CH as the trigger channel 

T + A + 0 Selects 10CH as the trigger channel 

T + A + 1 Selects 11CH as the trigger channel 

T + A + 2 Selects 12CH as the trigger channel 

T + A + 3 Selects 13CH as the trigger channel 

T + A + 4 Selects 14CH as the trigger channel 

T + A + 5 Selects 15CH as the trigger channel 

T + A + 6 Selects 16CH as the trigger channel 

T + E Selects EXT as the trigger channel 

T + { → or ← } Increases/decreases the trigger position 

T + { ↑ or ↓ } Increases/decreases the trigger level 

K Toggles between EDGE trigger and WIDTH trigger 

E Toggles between rise/fall 

W + T Toggles between over/under (in case of pulse width trigger) 

W + P Toggles between positive/negative polarity (in case of pulse width 
trigger) 
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Table 57: CH, MATH, X-Y Functions 

Keys Functions 

[CTRL] + 1 Toggles the waveform display of CH1 to ON/OFF 

[CTRL] + 2 Toggles the waveform display of CH2 to ON/OFF 

[CTRL] + 3 Toggles the waveform display of CH3 to ON/OFF 

[CTRL] + 4 Toggles the waveform display of CH4 to ON/OFF 

[CTRL] + 5 Toggles the waveform display of CH5 to ON/OFF 

[CTRL] + 6 Toggles the waveform display of CH6 to ON/OFF 

[CTRL] + 7 Toggles the waveform display of CH7 to ON/OFF 

[CTRL] + 8 Toggles the waveform display of CH8 to ON/OFF 

[CTRL] + 9 Toggles the waveform display of CH9 to ON/OFF 

[CTRL] + [A] + 0 Toggles the waveform display of CH10 to ON/OFF 

[CTRL] + [A] + 1 Toggles the waveform display of CH11 to ON/OFF 

[CTRL] + [A] + 2 Toggles the waveform display of CH12 to ON/OFF 

[CTRL] + [A] + 3 Toggles the waveform display of CH13 to ON/OFF 

[CTRL] + [A] + 4 Toggles the waveform display of CH14 to ON/OFF 

[CTRL] + [A] + 5 Toggles the waveform display of CH15 to ON/OFF 

[CTRL] + [A] + 6 Toggles the waveform display of CH16 to ON/OFF 

[SHIFT] + [CTRL] + 1 Toggles the waveform display of MATH1 to ON/OFF 

[SHIFT] + [CTRL] + 2 Toggles the waveform display of MATH2 to ON/OFF 

[SHIFT] + [CTRL] + 3 Toggles the waveform display of MATH3 to ON/OFF 

[SHIFT] + [CTRL] + 4 Toggles the waveform display of MATH4 to ON/OFF 

[SHIFT] + [CTRL] + 5 Toggles the waveform display of MATH5 to ON/OFF 

[SHIFT] + [CTRL] + 6 Toggles the waveform display of MATH6 to ON/OFF 

[SHIFT] + [CTRL] + 7 Toggles the waveform display of MATH7 to ON/OFF 

[SHIFT] + [CTRL] + 8 Toggles the waveform display of MATH8 to ON/OFF 

[SHIFT] + [Space] + 1 Toggles the waveform display of XY-1 to ON/OFF 

[SHIFT] + [Space] + 2 Toggles the waveform display of XY-2 to ON/OFF 

 

Table 58: File Menu Functions 

Keys Functions 

[CTRL] + C Copies to the clipboard (Copy to Clipboard)   

[CTRL] + P Prints 

 

※ Note that some of the keys may not operate in keyboards that are not equipped with the 

N key rollover function. 
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4.4.11 Notes 

● During the process of data reading, all CH data are not necessarily synchronized. 

Note that there is a time difference of about 0.2μs for reading each CH. 

● When closing the WAVE window, the currently set contents will be saved automatically. 

The saved contents will be reproduced when the system is started the next time. 

● Even when a program is compiled and variable information such as the variable name 

and address was changed while the WAVE window is started, the variable information in the 

WAVE window remains the same before compiling. In this case, download the program 

again, “Variable Information in WAVE Updated” will be displayed in the Console. 

When the WAVE window is opened again, the information will be updated to the new 

variable information. 

● If the computer goes into sleep mode during measurement, LAN will be disconnected and 

data recording will be terminated. 
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4.5 [Memory] Window 

The Memory window specifies the address, and displays the address for the amount of 256 

bytes. 

There are two methods to display this window. 

- Click the Window menu → Show Window → Memory 

- Click Memory of the tool buttons. 

 

When started, the following screen will be displayed. 

 

 

Figure 158: Memory Window 

 

Up to three Memory windows can be displayed at once. 
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4.5.1 Reading Memory 

Read the memory according to the following procedure: 

   

 

Figure 159: Reading Memory 

 

1) Enter the address in the Address field. 

Specify by a hexadecimal number. 

 

2) Execute reading 

Reading can be executed by the following two methods: 

 Click the Read button. 

 Press the Enter key in the Address field. 
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4.5.2 Context Menu 

Right-click to display the following context menu. 

 

 

Figure 160: Context Menu 

   

The items of the context menu are as follows: 

 

Table 59: Memory Window Context Menu 

Fields Contents 

Data Format This is for selecting the data format to be displayed. 

The data format can be selected from the following: 

Bin: Binary number 

Dec(S): Signed decimal number 

Dec(U): Unsigned decimal number 

Hex: Hexadecimal number 

Float: Floating point (32bit) 

Double: Floating point (64 bit) 

Data Size This is for selecting the collected size of data to be displayed. The 

data size can be selected from the following: 

1 byte 

2 byte 

4 byte 

8 byte 

Data Endianness This is for selecting the endian to be displayed. 

The endian can be selected from the following: 

Little endian 

Big endian 

Copy This is for copying the selected range to the clipboard. 
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4.5.3 Notes 

● When an address not disclosed to a user is specified, the masked address will be 

displayed as "********." 
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4.6 [Data Recorder] Window 

The Data Recorder window displays the waveforms of specified variables during sampling. 

It also saves the sampled data. 

In Data Recorder, variables for up to 32 CH can be registered to display the waveforms. 

 

4.6.1 Starting 

There are two methods to display this window. 

- Click the Window menu → Show Window → [Data Recorder] 

- Click Data Rec on the tool buttons. 

 

 

Figure 161: [Data Recorder] Window 
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4.6.2 Screen Structure 

The screen structure of Data Recorder is as shown below: 

 

 

Figure 162: Control Panel Window 
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Outline 
view graph

Enlarged 
view graph

 

Figure 163: Graph Window 

 

The contents of each window are as follows: 

 

Table 60: Contents of Data Recorder Window 

Windows Contents 

Control panel 

window 

This window is for specifying the display conditions and trigger 

conditions. 

When this window is closed, the graph window and FFT window will 

also be closed automatically. 

Graph window Displays the outline view graph and enlarged view graph. 

The outline view graph displays maximum data. 

[MAXIMUM DISPLAY] displays data in a specified time frame. 
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4.6.3 Outline of Data Recorder Function 

The Data Recorder function is provided with several settings that are required to display a 

waveform. This section describes the outline of these functions. See description of each 

function for details. 

 

Changing 

of CH tabs

POSITION

setting

y-axis range 

setting

Variable selection

Display format 

setting

Trigger 

conditions 

setting

Sampling 

frequency setting

x-axis range setting of 

enlarged graph display

Run/ Stop

Cursor 

ON/OFF

 

Figure 164: Explanatory View of Each Function 

 

※ Except that the display of the applicable channels of CH 5 to 32 changes to 5 to 32, the 

other functions are the same as the above screen. 
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4.6.4 Control Panel Window Functions 

This section describes each of the functions on the Data Recorder control panel window. In 

the control panel window, data sampling, various display changes, setting of each function, 

etc. can be performed. 

 

1) Data Sampling 

Click the RUN/STOP button to begin data sampling. While running, sampling begins with 

sampling period settings. However, when waveforms are refreshed, the timing is different 

from sampling period. 

 

 

 

Figure 165: Display while STOP 

 

The displays changes to the following while RUN. 

 

 

Figure 166: Display while RUN 

 

Click the RUN/STOP button again to end data sampling. 
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2) Cursor ON/OFF 

To display the cursor on the enlarged view graph, click the CURSOR button on the control 

panel window. 

 

The cursor is effective at [STOP] or [Display Hold] 

During [Display Hold], data sampling continues in [RUN] mode and waveform doesn’t 

refresh. Sampled data can be displayed in a specified time frame. 

 

 When cursor display is OFF 

 When cursor display is ON 

Figure 167: [CURSOR] Button Status 

 

When the cursor display is ON, the values of Cursor A, Cursor B, |A-B| and 1/|A-B| will be 

displayed on the status bar of the graph window. In each CH area, the cursor values of "-A-" 

and "-B-" will be displayed on the lower part of the enlarged view graph. 

To move Cursor A and Cursor B, move the mouse over the cursor character ("A" and "B") of 

the enlarged view window, and drag to a position. 

Cursor display ON: Displays the portion 

indicated by the arrows

Displays the values 

of cursors A and B
Displays the values on the 

status bar during ON  

Figure 168: Status when cursor display is ON 
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3) X-axis setting 

x-axis settings are displayed in [HORIZONTAL]. 

 

 

Figure 169: [HORIZONTAL] 

 

The following items are displayed under [HORIZONTAL]. 

 

Table 61: Items in [HORIZONTAL] 

Items Contents 

Auto Scale Automatic scaling of x-axis for enlarged graph view. 

START Displays the time for x-axis in enlarged graph. This value refers to the 

starting time of recording. There are 3 ways to change the value: 

(i) click on the left/right button in the box 

(ii) key in value directly into textbox 

(iii) adjust the scroll bar at the bottom of enlarged graph. 

SEC/ DIV x-axis range setting of enlarged graph display. 

RANGE Magnification setting of enlarged graph setting. The white box 

displayingthe range will be changed. 0.01%~100% can be displayed. 

However, the actual display will be based on [SEC/DIV].  

POSITION Displays the position setting of enlarged graph display. This value 

refers to the position of the white box. There are 3 ways to change the 

value: 

(i) click on the left/right button in the box 

(ii) key in value directly into textbox 

(iii) adjust the marker ▼ at the top of the graph. 
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The above settings are displayed in the image below. 

 

 

Figure 170: Enlarged Display of Waveform 

 

4) Sampling Period Setting 

Data sampling period is displayed under [SAMPLING]. 

 

 

Figure 171: [SAMPLING] 

 

The sampling period is in the range of 10ms ～ 10s. 

   

※ Take note that when the graphical data is refreshed, the interval is different from 

sampling period. 

Graduation width of x-axis 

of outline view graph 

POSITION and RANGE enclosed 

in white frame is displayed in an 

enlarged scale 

Graduation width of x-axis of enlarged 

view graph according to [SEC/DIV] 
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5) TRIGGER Settings 

Trigger functions are available in Data Recorder. If any trigger condition is met, data 

sampling stops after the specified time period. Refer to the image below for [TRIGGER] 

setting. 

 

 

Figure 172: [TRIGGER] Setting 

 

The following items are displayed under [TRIGGER]. 

 

Table 62: [TRIGGER] Setting 

Items Contents 

ENABLE Enable or disable trigger. Check the box to enable trigger. 

LEVEL Trigger level settings 

DELAY The specified time for data sampling to stop after trigger condition is met. 

Trigger CH Trigger channel settings 

Edge Trigger rise/fall settings 
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6) CH1-32 Data Sampling Settings 

To change the setting of the waveform display of CH1 to 32 to ON/OFF, click the ON/OFF 

button provided for each CH on the control panel window as shown below. 

 

 

Figure 173: [ON/ OFF] Key 
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7) Extension Window 

Up to 4 extension windows can be selected for CH1-32. In the image below, click on [Win1] 

to change the display of waveform. [Win1]～[Win4] can be switched.  

 

 

Figure 174: [Win1] 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 179/217 2017/09/19 

 

8) Setting Offset 

Clicking the OFFSET button of each CH displays the following screen and allows the Offset 

value to be set. To set the value, enter the Offset value directly. 

 

Figure 175: Offset Value Setting (CH1) 

 

The Offset function is for displaying the value in which a fixed value (Offset value) is added 

to the target variable by the waveform display software. All the values used for numerical 

processing and display by the waveform display software are the values after the Offset is 

added. Note that offset is also added to trigger level. 
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9) Selecting Variables 

To select the variable to be displayed, click the pull-down menu (▼ button) of VARIABLE on 

the control panel window. 

 

 

Figure 176: Variable Selection 

 

The variable can be selected from the following two methods. 

- Select a variable name with the mouse. 

- When the first character of a variable name is entered, the applicable variable name will be 

selected automatically. 

 

The variables listed in VARIABLE are displayed based on the variable information file 

automatically created by PE-ViewX. 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 181/217 2017/09/19 

 

10) Selecting display colors of waveform 

 

To set the waveform color of each CH, click the color list. The following color selection dialog 

will be displayed. 

 

 

Figure 177: Waveform Color Setting 

 
11) Setting POSITION 

 

To set the POSITION of CH1 to 32, set the value in POSITION as follows: 

 

 

Figure 178: Setting POSITION 

  

The position can be set by the following three methods. 

- Place the cursor on the dial, and rotate the mouse wheel. 

- Click the Up/Down buttons of the list box. 

- Directly enter a value. 

 

※ The setting range is from "(-4xVAL/DIV) to (4xVAL/DIV)." 
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4.6.5 Graph Window Structure 

 

This section describes the structure of the graph window. 

The structure is as follows: 

 

Menu

Outline 

view graph

Enlarged 

view graph

Disp1/ Disp2

Status bar

Display Freeze/ Display Resume
 

Figure 179: Graph Window Structure 

 

1) Menu 

The menu consists of File / Option. 

See "4.6.6 Processing Waveform Data (File Menu)" and "4.6.7 Waveform Display Related 

Settings (Option Menu)" for the details.
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2) Outline view graph 

The outline view graph displays all the acquired waveform data. 

The details are as follows: 

 

Scroll bar

POSITION Enlarged view graph area

x-axis range

HDD free space

Time frame for 

recording data  

Figure 180: Outline View Graph Structure 

 

Table 63: Outline View Graph Structure 

Name Functions 

POSITION Indicates the POSITION value set on each CH tab. 

HDD free space Real time display of HDD free space. Data sampling storage 
depends on HDD free space. 

Enlarged view graph 

area 

 

The area enclosed in the white frame in the outline view 
graph. This area is enlarged and displayed on the enlarged 
view graph. The range of the white frame is specified by the 
RANGE and POSITION. Up to 4 windows can be displayed. 

x-axis range Indicates the range of the x-axis (SEC/DIV) of the outline view 
graph. 

Time frame for recording 
data 

Displays the time frame of outline graph. 

Scroll bar In case when the range of sampling data (x-axis range x 10) 
exceeds the range, move the scroll bar to display desired 
data. 

 

Data Recorder saves the outline graphical data in memory when data sampling begins. 

Hence, there is a maximum limit of storage. The setting is under Option → Maximum 

Display. 
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3) Enlarged view graph 

The enlarged view graph enlarges and displays the area specified in the outline view graph. 

Up to 4 windows can be displayed. 

The details are as follows: 

 

Variable 

information 

of each CH

Disp1/ Disp2

x-axis range Time frame for recording data

POSITION

 

Figure 181: Enlarged View Graph Structure 

 

Table 64: Enlarged View Graph Structure 

Name Functions 

POSITION  Indicates the POSITION value set on each CH tab. 

Disp1/ Disp2 Displays the values set in the [Disp1/Disp2] fields. 
See "4) Disp1/Disp2" on the next page for details. 

x-axis range Indicates the range of the X-axis (SEC/DIV) of the outline 
view graph. 

Time frame for recording 
data 

Displays the time frame of outline graph. 

Variable information of 
each CH 

Displays the measurement condition of each CH and the 
values in cursors A/B. 
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4) Disp1/Disp2 

The contents set in these fields are displayed in the enlarged view graph as described on 

the previous page. 

The details are as follows: 

 

 

Change of display / hide

Display channels Display items
 

Figure 182: Disp1/Disp2 Structure 

 

Table 65: Disp1/Disp2 Structure 

Name Functions 

Change of display / hide Changes between display/hide. 

Display channels For setting the channels to be displayed. 

Can be selected from CH1 to 32. 

Display items Can be selected from the following items: 

Value A: 

  Displays the value of cursor A. 

Value B: 

Displays the value of cursor B. 
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5) Status bar 

The status bar displays the following items. 

 

Sampling cycle Record length

Time between A-B Frequency between A-B Position of A-B  

Figure 183: Status Bar Structure 

 

Table 66: Status Bar Structure 

Name Functions 

Time between A-B Displays the time difference between cursor A and cursor B. 

Frequency between A-B Displays the inverse, i.e. the frequency of the time 

difference between cursor A and cursor B. 

Position of A and B Displays the position on the time of cursor A and cursor B. 
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6) Display Hold/ Display Resume 

During data sampling, only waveform refresh can be terminated. Move the scroll bar to 

desired time frame to observe data. By clicking [Display Hold] on left side of status bar, data 

refresh is terminated. 

 

 

Figure 184: [Display Hold] 

 

Click [Display Resume] to refresh waveform. The latest waveform will be updated.  

 

 

Figure 185: [Display Resume] 

 

[Display Hold]/ [Display Resume] are only effective during RUN. They are disabled during 

STOP. 

 

 

Figure 186: During disabled condition 
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4.6.6 Processing Waveform Data ([File] Menu) 

This section describes the functions of the File menu of the graph window. 

The main functions include the Load and Save function of sampled data. The following 

describes each of the functions. Since the File menu cannot be used while running, stop the 

operation before use. 

 

1) Loading sampling data ([Load Data...])  

The sampling data can be loaded. Select the File menu → Load Data…. When the file to be 

loaded is specified, the following dialog will be displayed. Click the OK button to complete 

the loading. 

 

 

Figure 187: Sampling Data Loading Completed Dialog 

 

※ Relationship between the offset function and data saving 

The Offset function is for displaying the value in which a fixed value (Offset value) is added 

to the target variable by Data Recorder. All the values used for numerical processing and 

display by Data Recorder are the values after the Offset is added. 

However, the Offset value is not included in the saved waveform data. When the saved 

waveform data is read to Data Recorder, the data including the Offset value set when the 

waveform data is read will be displayed. Pay particular attention to this point. 
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2) Save Sampling Data Settings ([Log Settings]) 

All sampled data can be saved in a file. Before sampling, go to File → Log Settings → Log 

Settings. The following dialog is displayed. 

 

 

Figure 188: [Log Settings] Dialog 
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The following items are displayed under [Log Settings]. 

 

Table 67: [Log Settings] Dialog Items 

Items Contents 

Save Data Log Sampling data will be saved in this setting. Check to save file. 

Save Path Set path for saving. 

Scene Set scene for saving. 

File Name Set name for saving. 

Save method Set method of saving. 

Interval: save at specified interval. 

Range of 1s ～ 99h59m59s. 

Schedule: save at specified time frame. For example, once a day. 

Comment Set comments for scene. It will be displayed in File → Log 

Management. 

 

The file will be saved in the following format. 

 

[Save Path]¥[Scene]¥[File Name]_YearMonthDayTime_Number.csv 

 

The sequence starts from zero, in order of data recording. 

 

For example) 

      Save Path：c:¥log 

   Scene：Scene_1 

      File Name：Data_1 

    

   ==> c:¥log¥Scene_1¥Data_1_ YearMonthDayTime_0.csv 

          c:¥log¥Scene_1¥Data_1_ YearMonthDayTime_1.csv 

c:¥log¥Scene_1¥Data_1_ YearMonthDayTime_2.csv 

…. 
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3) Save file management ([Log Management]) 

File → Log Managementment → Log Management for file management. The dialog will 

appear as below.  

 

 

Figure 189: [Log Management] Dialog 

 

The following items are displayed under [Log Management]. 

 

Table 68: [Log Management] Dialog Items 

Item Contents 

Scene Displays scene name. 

Comment (Left) Displays comments for Scene. 

Filename Displays filename includuing Scene name. 

Comment (Right) Displays/refreshes comments for each file. 

[Browse…] Selects path for saving file. The settings are under [Save Path]. 

This displays all files in this path. 

Delete Deletes selected files. 

 

The image below displays an example. 
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Figure 190: An example of Log Management 

 

4) Printing ([Print]) 
The contents displayed in the graph window can be printed. 

Select the File menu → Print. 

 

5) Print preview ([Print Preview]) 

The contents to be printed can be previewed. 

Select the File menu → Print Preview. 
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4.6.7 Waveform Display Related Settings ([Option] Menu) 
This section describes the functions of the Option menu of the graph window. 

The settings related to the waveform display are performed in this menu. 

 

1) Sampling Data Search 

The image below displays the search for sampling data when the conditions are fulfilled. To 

search, go to Option → Search. The dialog appears as below.  

 

 

Figure 191: [Search] Dialog 
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The following items are displayed under [Search]. 

 

Table 69: [Search] Dialog Items 

Item Contents 

Channel Selects channel 

Variable Displays variables for selected channel. 

Method Setting for search method as follows: 

Edge: Search for Rise/Fall. Reference value is determined in [Level]. 

Peak: Search by Maximum/Minimum 

Click [Left] to search for maximum/minimum in the left direction. 

Click [Right] to search for maximum/minimum in the right direction. 

Left Search towards the left, with center based on outline graph view. 

Right Search towards the right, with center based on outline graph view. 

Close Close dialog. 

 

A red line will appear as below when the search conditions are met.  

The example shows a search example for rising edge at Level 0.5. 

A red line is displayed when 

search conditions are met.

 

Figure 192: Example of search results 
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2) Maximum time frame setting ([Maximum Display]) 

The setting for maximum time frame for graphical display is under Option → Maximum 

Display. For example, when the setting is 3 hour, the maximum of 3 hour data can be 

displayed. The older data will not be reflected. The dialog is displayed below. 

 

 

Figure 193: Maximum Display 

 

※ Data Recorder saves sampling data from the start in the time frame memory. The 

memory size is related to the following parameters.  

- [Maximum Display]: maximum time for recording 

- [SAMPLING]: sampling period 

 

In case when memory is insufficient, the error message will occur. Reduce [Maximum 

Display] or increase the interval of sampling period.  
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3) Setting display color ([Set System Color]) 

To set the background color and cursor color of the graph window, click the Option menu → 

Set System Color to display the following dialog. 

 

 

 

Figure 194: Background Color and Cursor Color Setting 

 
Back Color : Background color of graph window 

System Color : Grid line color of graph window 

Cursor A : Display color of Cursor A 

Cursor B : Display color of Cursor B 

Cursor Grab : Display color when setting Cursor and Trigger 

Cursor Grab refers to the color displayed when Cursor A, 

Cursor B, trigger position and the trigger level are being 

moved in the graph window while dragging by the mouse. 

 

4) Setting waveform pixel size ([Pixel Size]) 

The waveform pixel size of the graph window can be set. 

Select the Option menu → Pixel Size. 

The size can be set from Small, Medium or Large. 

 

5) Changing interpolation display of waveform ([Smooth]) 

Whether to interpolate the data for the sampling point of the waveform of the graph window 

to be displayed can be set. 

Select the Option menu → Smooth. 

When this function is set to ON, the interpolated waveform data will be displayed 
 

6) Setting graduation lines of waveform ([Grid Type]) 

The type of graduation line (grid line) of the graph window can be set. 

Select the Option menu → Grid Type. 

The type can be set between Dot or Line. 
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7) Setting display items ([Display Item]) 

The items displayed on the lower part of the enlarged view graph can be set. 

Select the Option menu → Display Item. 

 

 

Figure 195: [Display Item] Dialog 
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4.6.8 Notes 

● During the process of data reading, all CH data are not necessarily synchronized. 

Note that there is a time difference for reading each CH. 

● When closing the Data Rec window, the currently set contents will be saved automatically. 

The saved contents will be reproduced when the system is started the next time. 

● Even when a program is compiled and variable information such as the variable name and 

address was changed while the Data Rec window is started, the variable information in the 

Data Rec window remains the same before compiling. In this case, download the program 

again, “Variable Information in WAVE Updated” will be displayed in the Console. 

When the Data Rec window is opened again, the information will be updated to the new 

variable information. 

● If the computer goes into sleep mode during measurement, LAN will be disconnected and 

data recording will be terminated. 
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4.7 [Event Viewer] window 

[Event Viewer] window acquires events, which are data that is registered to the  

program code, and displays them. 

This window displays the execution history of the functions in the program.  

 

4.7.1 Starting 

    There are two ways to display this window. 

    ●[Window] menu > [Show Window] > [Event Viewer] 

●Click [Event] button in tool buttons 

 

The below window is displayed. 

 

Figure 196: [Event Viewer] Window 
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4.7.2 Screen Structure 

     Screen structure of Event Viewer is as follows. 

 

 

Figure 197: Control Pannel Window 

 

 

Figure 198: Graph Window 
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The contents of each window are as follows. 

 

Figure 199: Screen structure of event viewer 

Window Contents 

Control panel window Set the trigger conditions, and start/ stop event viewer. 

Graph window closes when closing this window. 

Graph window Display events graph. 
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4.7.3 Control Panel Window Functions 

This chapter describes functions about control panel window. 

 

 

Figure 200: Each functions 

ACQ LED 

Run/ Stop 

Trigger mode settings 

Trigger position settings 

Trigger source settings 

Event formula settings 

X-axis settings 
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1) Acquiring Event 

Click the RUN/STOP button to acquire events. Continuous acquisition and single  

acquisition are performed in the trigger mode. 

While running, the status changes to the trigger standby state according to the trigger  

setting, and when the trigger starts the waveform will be updated. ACQ turns ON while 

event is being transferred.    

 

Figure 201: Display While Stopped 

 

  The displays changes to the following while running. 

 

Figure 202: Display While Running 

 

  Click the RUN/STOP button again to end the acquisition of the event. 

 

2) Trigger mode settings 

  ●AUTO 

The wave form is updated in synchronization with the trigger signal 

if the trigger signal occurs within a certain time ( equivalent to one screen time ). 

If the trigger signal doesn't occur, the wave form is updated after a certain  

time. 

 

●SINGLE 

If the trigger condition is met during RUN, the waveform is retrieved once and it stops.  

If the trigger condition is not met, the trigger enters into a “wait” state. 

 

Note that it is possible to change the trigger mode during running. 

 

3) X-axis settings 

  Set the range of the X-axis ( equivalent to time ). 

  The setting is from 1(us) to 2(s). 

  The total X-axis time of graph screen is 10 times this value. 
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4) Trigger position settings 

   Set the trigger position. 

   This value defines the ratio of pre-trigger and post-trigger. 

 

5) Trigger source setttings 

   Trigger source is an execution point which is registered to the program. 

   The items of trigger source are as follows. 

     

Table 70: List of trigger source 

Items Contents 

MajorID Specify Major ID which is registered to the program. 

Set the following. 

 

●Function name 

●32bit value( decimal number or hexadecimal number ) 

  Add “0x” to the top when specifying hexadecimal number. 

 

All function names are registered to list box. 

SubID Specify Sub ID which is registered to the program. 

Set the following. 

 

●EV_SUB_ENTER( = 0 ) 

●EV_SUB_LEAVE( = 1 ) 

●32bit value which is 3 or more.  

( decimal number or hexadecimal number ) 

Add “0x” to the top when specifying hexadecimal number. 

 

“EV_SUB_ENTER”/ “EV_SUB_LEAVE” is registered to list 

box. 

 

For more details about Major ID/ Sub ID, refer to the [5.1.9 MWPE4-C6657 Board and 

other Functions] in Function Reference Manual. 
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6) Event formula settings 

  Event formula is a formula which defines the trigger search condition. 

  The following event formulas can be used. 

   

Table 71: Event formula 

Event formula Contents 

Trigger source 

(0 to 3) 

Trigger occurs when meeting specified trigger source.  

or( Trigger source A, 

     Trigger source B ) 

Trigger occurs when meeting either “Trigger source A” 

 or “Trigger source B”. 

delay( Trigger source, 

         Time ) 

Trigger occurs after specified time from meeting 

first trigger source. 

 

Time is second. The following suffix is available. 

n: nanosecond 

u: microsecond 

m: millisecond 

delay2( Trigger source, 

          Time ) 

Trigger occurs after specified time from meeting 

last trigger source. 

 

Last trigger source is judged if next trigger source 

doesn’t meet within specified time. 

Time unit and suffix is the same as “delay()” event. 

over( Trigger Source A, 

       Trigger Source B, 

       Time ) 

 

Trigger occurs if “Trigger source B” doesn’t 

meet within specified time after meeting “Trigger  

source A”. 

Time unit and suffix is the same as “delay()” event. 

 

The above 2) to 6) can be changed while running Event Viewer. 

Then new trigger condition is applied. 
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4.7.4 Graph Window Functions 

     This chapter describes the functions of Graph window. 

 

 

Figure 203: Each functions 

 

 

 

1)Major ID to display 

  Specify Major ID on Graph. 

  All functions are registered to the list box. 

  Other than functions, 32bit value can be specified. 

( Decimal or hexadecimal number. ) 

Add “0x” to the top when specifying hexadecimal number. 

 

2)Trigger position 

  Displayed trigger position specified by control panel window. 

 

3)Hit position 

  Displayed trigger hit position in the current wave. 

 

Hit Position 

Trigger Position 

Graph 

X-axis range 

Displayed events count 
Un-displayed events count 

Major ID to  

display 
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4)Graph 

  Displayed graph based on received events. 

 

5)X-axis range 

  Displayed X-axis range. 

  Total graph time of x-axis is 10 times this value. 

 

6)Displayed events count 

  Displayed events count on graph from the received events. 

  8000 or less points are displayed. 

  X-axis direction is aligned based on hit position, so some points may be 

  excluded from graph, and excluded points are not displayed. 

 

7)Un-displayed events count 

  Un-displayed events count on graph from the received events. 

  More than 8000 points are not displayed. 

  And as described 6), some points may be not displayed by aligning x-axis direction. 
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8)Context Menu 

  Right-click to display the below context menu. 

 

 

Figure 204: Context menu 

 

   Items of context menu are as follows. 

Figure 205: Context menu 

Menu Contents 

Settings Set display conditions. 

[Graph Settings] dialog displayed. 

Save Wave Data Save displayed events. 

Save Wave Data as CSV Save displayed events as csv format for post-analysis. 

Load Wave Data Load saved events. 

Save Trigger Condition Save current trigger condtions. 

Load Trigger Condition Load saved trigger conditions. 

 



 

PE-ViewX User's Guide 
Doc. No.: 131170-A2-055C Page 209/217 2017/09/19 

 

●[Graph Settings] dialog 

 Right-click > Context menu > Click [Settings] to display [Graph Settings] dialog. 

 

 

Figure 206: [Graph Settings] dialog 

 

Settings items are as follows. 

Table 72: Settings items of [Graph Settings] dialog 

Items Contents 

Background Set the background color. 

Frame Set the frame color. 

Line Set the line color. 

Pixel Width Set the line/ pixel width. 

Smooth Toggle dot diplay/ line display. 

Max Event Set the count of Major ID to display from 2 to 16. 

Display 

Item 

Mode 
ToolTip Display parameters of events with tooltip. 

All Points Dispay all parameters of events on graph. 

SubID Toggle diplay/ hide of sub ID. 

Option Toggle diplay/ hide of option. 

Label Toggle diplay/ hide of label. 

OK Save the settings and close the dialog. 

Cancel Cancel the settings and close the dialog. 

Apply Save the settings. 
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4.7.5 Notes 

      To use event viewer, it is necessary to call PEOS functions in version 3.04 or more 

      to initialize and register the execution points. 

For more details, refer to [5.12  Debug Function Group] in function reference  

manual. 

The kernel version of DSP board needs to be upgraded to version 3.03 or more. 
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Chapter 5 Troubleshooting 

This chapter describes the troubles which may occur, and the solution. 

 

No.1) 

(Phenomenon) 

A connection timeout occurred while starting, and the following dialog is displayed. 

 

Figure 207: Connection Timeout 

 

(Cause and measures) 

       It is not properly connected to PE-Expert4. 

       Check the following items: 

       ●Does the LED of PE-Expert4 remain ON normally? 

 

If normal, the 1st, 5th and 6th LEDs from the top should be ON. 

Regarding the starting sequence, start PE-ViewX after PE-Expert4 is started. 

 

●Is the IP address connected to PE-Expert4 from PE-ViewX set correctly? 

 

Click the Setting menu → TCP/IP → enter the IP address in the TCP/IP Settings 

dialog. 

 

The default setting of IP address of PE-Expert4 is as follows: 

IP Address : 192.168.1.100 

Subnet Mask : 255.255.255.0 

Default Gateway : 192.168.1.101 

Port No.  : 10000 
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●Does the IP address of the PC being used conform to the above address? 

 

Click Control Panel of the PC → Network and Internet → Network and Sharing 

Center → Change Adapter Settings to open the properties of the applicable 

network. Select Local Area Connection and right click, select Properties 

Select Properties of Internet Protocol Version 4 (TCPipv4), and confirm the IP 

address of the PC. 

As shown below, change the values enclosed in red to the same values set in 

PE-ViewX. 

Set the values enclosed in blue to values different than the values set in PE-ViewX. 

 

Set to the same values 

set in PE-ViewX

Set to values different than 

the values set in PE-ViewX  

Figure 208: Internet Protocol Version 4 (TCPipv4) on PC 

 

●If the connection still cannot be made even after the above setting is set correctly, 

turn OFF the Internet security and firewall. 

There are cases where the connection cannot be made due to the Internet security 

or firewall. 
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No.2) 

(Phenomenon) 

The following dialog "Variable information (*.def file) is not loaded yet. So use of 

communication function will be limited." is displayed. 

 

 

Figure 209: Variable Information has not been Read 

 

(Cause and measures) 

The variable information is saved in the *.def file which is created automatically 

during a compile. 

This message is displayed at the following timing when a project is not selected, or 

the *.def file has not yet been created. 

 When PE-ViewX is started. 

 When WAVE is started. 

 

The *.def file will be created after a project is selected, and the compiling is 

completed normally. Subsequently, this message will no longer be displayed. 
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No.3) 

(Phenomenon) 

The system has been operating normally, but recently, Inspector and WAVE was forced to 

stop 3~4 times. 

 

(Cause and measures) 

There are reports that Raptr software interfered with *.dll (a file which is necessary for 

PE-ViewX operation) on the same computer. In this case, uninstall Raptr software from 

Control Panel. 
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No.4) 

(Phenomenon) 

No events may be occurred for several milliseconds when using event viewer. 

 

(Cause and measures) 

It is due to high CPU usage of DSP board when using event formula ( over/ delay/ delay2 ). 

These event formulas increase the probability of losing events. 

Then the return value of “ev_log()”/ “ev_logP()” functions are 0. 

In this case, stop WAVE or PE-Meter. 

This problem will be fixed in later version. 
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Revision History 

 

Document No. Revision Date Revisions 

121098-A2-052 2013/10/17 ●New document 

131170-A2-055A 2016/11/21 ●Revised based on 131170-A2-050K 

131170-A2-055B 2017/03/17 ●Revised based on 131170-A2-050L 

131170-A2-055C 2017/09/19 ●Added chapter [1.4 Regarding connection to  

PE-Expert4] 

●Added the following commands to 

 “2) command” of chapter 

[3.3.6 External Coupling] 

     wave 

     dos 

     output 

●Added chapter [3.3.7 Offset of timeout] 

●Added chapter [3.3.8 Data Table] 

●Added description about changing font size 

to chapter [4.2 Console Window] 

●Added “15)On-Chip WAVE settings” to 

chapter [4.4.4 Control Panel Window  

Functions] 

●Added chapter [4.7 [Event Viewer] window] 

●Added “No.4” to chapter 

[Chapter 5 Troubleshooting] 

 

( Based on 131170-A2-050M ) 
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